Opened 7 years ago

Closed 4 months ago

#9162 closed bug (fixed)

Writing large file to USB causes KDL

Reported by: dsuden Owned by: bonefish
Priority: normal Milestone: R1
Component: System/Kernel Version: R1/alpha4
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I have A4 installed and in all other respects it has been VERY solid...but when writing a large (4 gigabyte) file to a 16 gigabyte-capacity USB stick, it manages to KDL the system every time, at some point during the copying process. I have tried it about six times, on two different computers. Both computers are AM3 Athlon based, if that enters into it at all. I have attached a screen grab showing the KDL message.

I should mention the USB stick is formatted Fat32, so that I can bring the file over to another computer.

Attachments (2)

IMG_0479.JPG (1018.9 KB ) - added by dsuden 7 years ago.
Screen grab of KDL that happens when copying large file to USB stick in A4
IMG_0480.JPG (138.4 KB ) - added by dsuden 7 years ago.
Frozen window when copying large file to USB stick in A 4.1

Download all attachments as: .zip

Change History (9)

by dsuden, 7 years ago

Attachment: IMG_0479.JPG added

Screen grab of KDL that happens when copying large file to USB stick in A4

comment:1 by anevilyak, 7 years ago

Component: - GeneralSystem/Kernel
Owner: changed from nobody to bonefish
Status: newassigned

comment:2 by kallisti5, 7 years ago

could you try again on R1A4.1?

There was an issue which could affect any low-level drivers. (not likely, but it's an easy thing to omit from troubleshooting :)

in reply to:  2 comment:3 by mmlr, 7 years ago

Replying to kallisti5:

There was an issue which could affect any low-level drivers.

No, it does not affect any drivers. The scope of that bug was limited to modules and possible a special case in the block cache, so updating won't help.

This bug looks pretty much the same as #4473. It's interesting that you have a reproducible test case. I could imagine a USB timeout being at work, that then propagates an error up, indirectly causing the close resulting in a double close.

comment:4 by dsuden, 7 years ago

mmlr I will try. Previously the KDL screen wouldn't let me type anything...but I'll give it a shot and report back.

Meanwhile, in case it's useful, I tried downloading and installing 4.1 and again attempting to copy to the USB stick. This time it didn't KDL. Instead the window sort of froze and went white on me. I've attached a photo of what I saw. The entire OS wasn't completely frozen...I could still move the mouse, and even click the Start button in the deskbar and it responded, though I couldn't open folders or anything. When selecting the option to restart, Haiku reported it would tidy up, and that's as far as it got.

by dsuden, 7 years ago

Attachment: IMG_0480.JPG added

Frozen window when copying large file to USB stick in A 4.1

comment:5 by pulkomandy, 5 years ago

Does this still happen? Also, does it happen only on FAT32 volumes or does it also happen if the USB disk target is formatted as BFS?

comment:6 by waddlesplash, 11 months ago

Dane: Could you retest this and all your other long-opened tickets and see which ones are fixed?

comment:7 by waddlesplash, 4 months ago

Resolution: fixed
Status: assignedclosed

Upon closer inspection this indeed seems to be the same as #4473, which was partially fixed by axeld (but in a way that caused more KDLs), and then again later by me, in a more permanent fashion. So this can be finally closed.

Note: See TracTickets for help on using tickets.