Opened 10 years ago

Closed 11 months ago

#4473 closed bug (fixed)

KDL in put_fd at team exit - unhandled page fault in kernel space at 0xdeadbf1b

Reported by: jonas.kirilla Owned by: nobody
Priority: normal Milestone: R1
Component: System/Kernel Version: R1/Development
Keywords: vfs fd Cc:
Blocked By: Blocking: #6161, #11772, #11811
Has a Patch: no Platform: All

Description

See attached file. Excerpt:

16 81383bfc (+ 104) 80096929   <kernel_x86>:put_fd + 0x005d
17 81383c64 (+  64) 800a798c   <kernel_x86> vfs_free_io_context(io_context*: 0x8169ce14) + 0x0084
18 81383ca4 (+  48) 800a7a15   <kernel_x86>:vfs_put_io_context + 0x0029
19 81383cd4 (+ 112) 80056e84   <kernel_x86>:team_delete_team + 0x0224
20 81383d44 (+ 368) 8005ab24   <kernel_x86>:thread_exit + 0x0470
21 81383eb4 (+  80) 8004f535   <kernel_x86>:handle_signals + 0x03d9
22 81383f04 (+  64) 8005b0fa   <kernel_x86>:thread_at_kernel_exit + 0x008e
23 81383f44 (+ 100) 800dfe4b   <kernel_x86>:kernel_exit_handle_signals + 0x0006

Attachments (3)

KDL_33050_put_fd.txt (3.2 KB ) - added by jonas.kirilla 10 years ago.
image.jpg (4.8 MB ) - added by UserPatrone 4 years ago.
IMG_20150901_112123761_HDR.jpg (73.3 KB ) - added by ttcoder 4 years ago.
Still occurs, however rarely: this one was Dane updating a package on a freshly installed hrev49137

Change History (14)

by jonas.kirilla, 10 years ago

Attachment: KDL_33050_put_fd.txt added

comment:1 by jonas.kirilla, 10 years ago

Could #4157 be related?

in reply to:  1 comment:2 by bonefish, 9 years ago

Keywords: vfs fd added

Replying to jonas.kirilla:

Could #4157 be related?

Yep.

comment:3 by bonefish, 9 years ago

Version: R1/pre-alpha1R1/alpha2

Apparently still with us in R1 alpha 2 (cf. #5936, http://dev.haiku-os.org/attachment/ticket/5936/shutdown-error.png).

comment:4 by bonefish, 9 years ago

Blocking: 6161 added

(In #6161) Duplicate of #4473.

comment:5 by diver, 4 years ago

Blocking: 11811 added

comment:6 by diver, 4 years ago

Blocking: 11772 added

comment:7 by UserPatrone, 4 years ago

Still here in hrev49556

by UserPatrone, 4 years ago

Attachment: image.jpg added

comment:8 by diver, 4 years ago

Version: R1/alpha2R1/Development

by ttcoder, 4 years ago

Still occurs, however rarely: this one was Dane updating a package on a freshly installed hrev49137

comment:9 by diver, 4 years ago

Could this be fixed by hrev49631?

comment:10 by axeld, 2 years ago

Owner: changed from axeld to nobody
Status: newassigned

comment:11 by waddlesplash, 11 months ago

Resolution: fixed
Status: assignedclosed

Sure looks like it. If not, please reopen.

Note: See TracTickets for help on using tickets.