Opened 7 years ago

Closed 7 months ago

#9167 closed bug (fixed)

KDL after plugging in USB-to-serial device

Reported by: dsuden Owned by: axeld
Priority: normal Milestone: R1
Component: Network & Internet/Stack Version: R1/alpha4
Keywords: Cc: ttcoder
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by diver)

Maybe this was caused by plugging in the USB-to-serial adapter while the computer was running instead of with it turned off...I've since done a reboot and we'll see if it happens again or not. But when I plugged one of those USB-2-Serial dongle adapters to a USB port on the back of my Haiku machine, I got the attached KDL.

KDL due to plugging in USB-2-Serial adapter while computer running

Attachments (1)

IMG_0482.JPG (960.2 KB) - added by dsuden 7 years ago.
KDL due to plugging in USB-2-Serial adapter while computer running

Download all attachments as: .zip

Change History (8)

Changed 7 years ago by dsuden

Attachment: IMG_0482.JPG added

KDL due to plugging in USB-2-Serial adapter while computer running

comment:1 Changed 7 years ago by anevilyak

Interestingly, the attached panic actually points towards a memory management issue in the network stack, and doesn't appear to be related to plugging that adapter in at first glance.

comment:2 Changed 7 years ago by dsuden

Might just have been coincidence in that case. We'll monitor the situation and see if it repeats itself and under what conditions.

comment:3 Changed 5 years ago by diver

Component: - GeneralNetwork & Internet/Stack
Description: modified (diff)
Owner: changed from nobody to axeld

comment:4 Changed 7 months ago by jackburton

No update in 6 years. Could be closed, I guess.

comment:5 Changed 7 months ago by diver

#5527 could be related.

comment:6 Changed 7 months ago by ttcoder

Cc: ttcoder added

This must have been the very sole time I ever saw "ObjectDepot" appear in a KDL for us in all those years, let alone for our stations. As to the UDP and TCP code, there were 2 bugs, the former was fixed in hrev51603 and we never saw it again.

So that one would be for the archives... I think dsuden will agree to close this too.

comment:7 Changed 7 months ago by waddlesplash

Resolution: fixed
Status: newclosed

Indeed, it looks like this was a duplicate of #5527, which was fixed.

Note: See TracTickets for help on using tickets.