Opened 7 years ago

Closed 5 months ago

#9169 closed bug (fixed)

No Desktop with TP X31 and ipw2100

Reported by: doppelhertz Owned by: nobody
Priority: normal Milestone: R1
Component: Drivers/Network/iprowifi2100 Version: R1/alpha4.1
Keywords: boot-failure Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

After installing R1/A4.1 and the ipw2100 WLAN firmware for my Thinkpad X31 the desktop never show up. Booting itself is ok but when the desktop should appear the screen only turns black (better: only the very dark grey of the backlight is visible). However, the system seems to try to connect to WLAN (WLAN status LED turns green). Waited 30 minutes, no change.

System: IBM Thinkpad X31 Graphics: ATI Radeon Mobility 7000 (M6LY) WLAN: Intel PRO/Wireless 2100

Attachments (4)

about_R1A4_1.jpeg (58.0 KB) - added by doppelhertz 7 years ago.
DSC_0225.jpg (574.6 KB) - added by doppelhertz 7 years ago.
listdev.txt (2.5 KB) - added by doppelhertz 7 years ago.
listimage_drivers.txt (2.0 KB) - added by doppelhertz 7 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 7 years ago by luroh

Blocking: 7665 added

Any chance of a grabbing a syslog?

Changed 7 years ago by doppelhertz

Attachment: about_R1A4_1.jpeg added

Changed 7 years ago by doppelhertz

Attachment: DSC_0225.jpg added

Changed 7 years ago by doppelhertz

Attachment: listdev.txt added

Changed 7 years ago by doppelhertz

Attachment: listimage_drivers.txt added

comment:2 in reply to:  1 Changed 7 years ago by doppelhertz

Replying to luroh:

Any chance of a grabbing a syslog?

Only via "debug syslog" > "Display syslog from previous session" and a photo (see DSC_0225.jpg), sorry.

comment:3 Changed 2 years ago by axeld

Owner: changed from axeld to nobody
Status: newassigned

comment:4 Changed 11 months ago by waddlesplash

Keywords: boot-failure added; WLAN X31 removed

comment:5 Changed 11 months ago by waddlesplash

Component: Network & Internet/WirelessDrivers/Network/iprowifi2100

comment:6 Changed 11 months ago by waddlesplash

Blocking: 7665 removed

comment:7 Changed 11 months ago by waddlesplash

Please retest after hrev52099.

comment:8 Changed 5 months ago by waddlesplash

Resolution: fixed
Status: assignedclosed

Probably fixed by mmu_man's changes to the compat layer's PCI handling. Please reopen if it's still reproducible.

Note: See TracTickets for help on using tickets.