Opened 8 years ago

Closed 10 months ago

Last modified 10 months ago

#9183 closed bug (invalid)

Intel HDA chip detected but failed to initialize sound - no audio device present

Reported by: loziniak Owned by: korli
Priority: normal Milestone: Unscheduled
Component: Drivers/Audio/HDA Version: R1/alpha4.1
Keywords: hda sound audio intel Cc:
Blocked By: Blocking:
Platform: x86

Description

I see no audio devices in my system (preferences/media). My computer is Lenovo S10-3t with Intel Atom N550 chipset.

Attachments (2)

syslog (302.2 KB ) - added by loziniak 8 years ago.
haiku syslog
listdev.txt (2.4 KB ) - added by loziniak 8 years ago.
listdev output

Download all attachments as: .zip

Change History (10)

by loziniak, 8 years ago

Attachment: syslog added

haiku syslog

by loziniak, 8 years ago

Attachment: listdev.txt added

listdev output

comment:1 by ttcoder, 8 years ago

I guess haiku devs will find this... interesting(ly odd) ! (i.e. "v255" and the multiple errors) :

HDA: Detected controller @ PCI:0:27:0, IRQ:22, type 8086/27d8 (17aa/390a)
...
hda: HDA v255.255, O:15/I:15/B:15, #SDO:6, 64bit:yes
...
hda: unable to reset controller
hda: reset_controller failed
...
hda: ERROR: Device/File/Resource busy(-2147483634)

comment:2 by marcusoverhagen, 8 years ago

Please test hrev44866

comment:3 by korli, 7 years ago

Is it reproducible on a current nightly?

comment:4 by pulkomandy, 2 years ago

Milestone: R1R1/beta2

comment:5 by pulkomandy, 17 months ago

Milestone: R1/beta2Unscheduled

Removing HDA audio tickets from Beta2 milestone, no one has worked on it and opensound is available at least as a stopgap.

comment:6 by waddlesplash, 10 months ago

Resolution: invalid
Status: newclosed

No reply.

comment:7 by bga, 10 months ago

Funny enough, this looks like the thing I just fixed. :)

comment:8 by waddlesplash, 10 months ago

It does, that's why I was looking at it. But it's not clear why a HDA chipset from so long ago would use 64bit addresses.

Note: See TracTickets for help on using tickets.