Opened 7 years ago

Closed 2 years ago

Last modified 14 months ago

#9199 closed bug (no change required)

Bootloader hangs after install

Reported by: TandyDandy Owned by: nobody
Priority: normal Milestone: R1
Component: - General Version: R1/alpha4.1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

I can boot from the CD and install Haiku without any apparent issues. After installation and a reboot, however, is when this problem appears.

Once the POST is complete, instead of continuing onto the bootloader, the system hangs at a blinking cursor (I can still press ctrl+alt+del to reboot the system). Holding down shift during or before this does not yield the usual additional options.

I've tried installing Haiku several times now (with and without safe mode enabled) and with different partitioning schemes but it's always the same problem. Disconnecting the second 120GB drive has no effect.

System information: Dell Dimension E521 BIOS version: 1.1.10 (latest) Processor: Athlon X2 4450e @ 2.3Ghz Chipset: Nvidia GeForce 6150LE Graphics: ATi All-in-Wonder 3650 HD Audio: Sigmatel 9227 Memory: 4GB (4x1GB) DDR2 667 in dual channel configuration (passes memtest) Hard drive: 320GB SATA 7200RPM @ SATA-0 Hard drive: 120GB SATA 7200RPM @ SATA-1

Change History (5)

comment:1 by TandyDandy, 7 years ago

I've just run across this by accident:

If I install Haiku onto the raw device (/dev/disk/ata/2/master/raw) instead of a partition (/dev/disk/ata/2/master/0), the bootloader appears after install, but cannot find any boot volumes.

comment:2 by TandyDandy, 7 years ago

Summary: Bootloader hangs after install on Dell E521Bootloader hangs after install

comment:3 by luroh, 7 years ago

Blocking: 7665 added

in reply to:  1 comment:4 by diver, 2 years ago

Resolution: no change required
Status: newclosed

Replying to TandyDandy:

I've just run across this by accident:

If I install Haiku onto the raw device (/dev/disk/ata/2/master/raw) instead of a partition (/dev/disk/ata/2/master/0), the bootloader appears after install, but cannot find any boot volumes.

This is likely a different issue altogether.

Anyway, since it's been 4 years and no one ran into this problem I'm going to close this one assuming that there was some problem with your boot manager. Please reopen if you can still reproduce it.

comment:5 by waddlesplash, 14 months ago

Blocking: 7665 removed
Note: See TracTickets for help on using tickets.