Opened 7 years ago

Closed 9 months ago

#9215 closed bug (invalid)

Intel 3945ABG Wireless LAN - not working properly

Reported by: Caylon Owned by: nobody
Priority: normal Milestone: R1
Component: Drivers/Network/iprowifi3945 Version: R1/alpha4.1
Keywords: Cc: Caylon
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I have a Laptop Benq Joybook R55, which has a button for WLAN(it is not s switch on/off, it is only a button). I installed the firmeware, but the WLAN did not work, there where no networks although I pressed the WLAN Button.

I restarted went into the booloader disabled ACPI, then pressed the WLAN button and continued booting, so after that all WLAN networks where shown. I attached two syslogs, at "syslog-not working" you can see that it says "Radio Transmitter is switched off" although I pressed the WLAN Button.

It is a Intel 3945ABG Wireless LAN device.

So It looks like I have to press the WLAN button before Haiku boots.

The other problem is that DHCP does not work.

Attachments (2)

syslog-not working (445.4 KB ) - added by Caylon 7 years ago.
syslog-ok (41.8 KB ) - added by Caylon 7 years ago.

Download all attachments as: .zip

Change History (6)

by Caylon, 7 years ago

Attachment: syslog-not working added

by Caylon, 7 years ago

Attachment: syslog-ok added

comment:1 by Caylon, 7 years ago

sorry DHCP works, I don't know why it didn't worked before...

comment:2 by waddlesplash, 15 months ago

The iprowifi3945 driver was synced with FreeBSD 11.1 in hrev52043; please retest.

comment:3 by cocobean, 15 months ago

@Rafael - On certain laptops, you have to make sure the Wifi button is active and WLAN radio is enabled in the BIOS. The WLAN light may not be active (lit) until the adapter is activated/enabled by the OS (linux/Windows/FBSD-tested). Seems once you disabled APIC, your WLAN and DHCP worked on your laptop.

Last edited 15 months ago by cocobean (previous) (diff)

comment:4 by waddlesplash, 9 months ago

Resolution: invalid
Status: newclosed

No reply in 6 months, closing as invalid.

Note: See TracTickets for help on using tickets.