Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#9258 closed bug (duplicate)

Terminal colors/colours don't work correctly.

Reported by: xray7224 Owned by: siarzhuk
Priority: normal Milestone: R1
Component: Applications/Terminal Version: R1/alpha4.1
Keywords: Cc:
Blocked By: #6510 Blocking:
Has a Patch: no Platform: All

Description

Hey,

I have been using tmux, irssi and identicurse (a curses based identi.ca client) via ssh and found that the colours often appear where they're not suppose to (spilling over from other areas). I have attached a screenshot to show this. Most notably this occurs in the irssi input box and occasionly sometimes the identicurse app will give text a white background (when the program isn't). I can varify using other terminals on other OS's don't do this and the problem is definitly in the haiku terminal (or library it uses).

This bug is around in alpha 4.1.

(check attached pictures to see it occuring)

Attachments (2)

irssi-fail.png (129.9 KB ) - added by xray7224 7 years ago.
Irssi exhibiting colour issue.
Identicurse-fail.png (99.9 KB ) - added by xray7224 7 years ago.
Identicurse exhibting colour issue.

Download all attachments as: .zip

Change History (7)

by xray7224, 7 years ago

Attachment: irssi-fail.png added

Irssi exhibiting colour issue.

by xray7224, 7 years ago

Attachment: Identicurse-fail.png added

Identicurse exhibting colour issue.

comment:1 by siarzhuk, 7 years ago

Owner: changed from jackburton to siarzhuk
Status: newassigned

comment:2 by siarzhuk, 7 years ago

Just curious, could you please try to redefine environment variable TERM to xterm-color and repeat your tests?

Yes, I confirm that this is known problem and I have it on my TODO list. :-|

comment:3 by augiedoggie, 7 years ago

duplicate of #6510

comment:4 by diver, 7 years ago

Blocked By: 6510 added
Resolution: duplicate
Status: assignedclosed

comment:5 by xray7224, 7 years ago

Accidently added a comment to this bug. I've posted it on the other one now (that this is a duplicate of)

Last edited 7 years ago by xray7224 (previous) (diff)
Note: See TracTickets for help on using tickets.