Opened 7 years ago

Closed 6 years ago

#9284 closed enhancement (fixed)

OptionalPackages for x86_64 that may need some extra help

Reported by: scottmc Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: - General Version: R1/alpha4.1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86-64

Description

We've got haikuporter sort of working now on x86_64, but there's a few key packages that are going to need a bit of help to fully unlock haikuporter. The big one is openssl, which blocks openssh, svn, git and others. That may not be too hard to fix as it looks to be just setting up the right parameters in config and Configure. The next one is xz-utils, since many new source tarballs are moving to .xz. This one looks like it's failing on some assembly code, so might be a bit more work. I'll add other blockers here as we run into them.

Change History (3)

comment:1 Changed 6 years ago by scottmc

There is now a package for openssh, still need one for XZ-Utils. openssh package added in hrev45105

comment:2 Changed 6 years ago by hamish

xz-utils builds fine for me on 64, after updating config.guess and config.sub.

comment:3 Changed 6 years ago by scottmc

Resolution: fixed
Status: newclosed

Closing as OptionalPackages are being replaced with .hpkg files and x86_64 is being handled in that process.

Note: See TracTickets for help on using tickets.