Opened 7 years ago

Closed 9 months ago

#9296 closed bug (fixed)

Crash when moving thru mail query results

Reported by: humdinger Owned by: mmlr
Priority: normal Milestone: R1
Component: Kits/libtracker.so Version: R1/alpha4.1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

This is alpha4.1

I've seen the following crash 3 times out of 5, but it's not 100% reproducible:

  • Query for new mail.
  • In the result window, filter for some string (with activated type-ahead filtering in Tracker).
  • Open a mail in Mail.
  • In Mail go to the next mail and trash it.
  • Move to next or previous mail (I'm not sure what I did exactly, I think navigating a bit thru next/prev mails does the trick...)

--> crash.

Twice I got this:

Thread 8074 caused an exception: Segment violation
[...]
[Switching to team /boot/system/Tracker (135) thread w>mailbox (8074)]
0x00406720 in node_ref::operator== () from /boot/system/lib/libbe.so
(gdb) bt
#0  0x00406720 in node_ref::operator== () from /boot/system/lib/libbe.so
#1  0x00628de2 in BPrivate::PoseList::FindAllPoses ()
   from /boot/system/lib/libtracker.so
#2  0x0063cd84 in BPrivate::BPoseView::AttributeChanged ()
   from /boot/system/lib/libtracker.so
#3  0x0063b674 in BPrivate::BPoseView::FSNotification ()
   from /boot/system/lib/libtracker.so
#4  0x00630758 in BPrivate::BPoseView::MessageReceived ()
   from /boot/system/lib/libtracker.so
#5  0x00653cba in BPrivate::BQueryPoseView::MessageReceived ()
   from /boot/system/lib/libtracker.so
#6  0x002ee4ef in BLooper::DispatchMessage () from /boot/system/lib/libbe.so
#7  0x003c73c5 in BWindow::DispatchMessage () from /boot/system/lib/libbe.so
#8  0x003cb788 in BWindow::task_looper () from /boot/system/lib/libbe.so
#9  0x002efa4b in BLooper::_task0_ () from /boot/system/lib/libbe.so
#10 0x007216e3 in thread_entry () from /boot/system/lib/libroot.so
#11 0x78033fec in ?? ()
(gdb)

And once this one:

Thread 8176 caused an exception: Segment violation
[...]
[Switching to team /boot/system/Tracker (8151) thread w>mailbox (8176)]
0x0061140a in BPrivate::Model::IsNodeOpen ()
   from /boot/system/lib/libtracker.so
(gdb) bt
#0  0x0061140a in BPrivate::Model::IsNodeOpen ()
   from /boot/system/lib/libtracker.so
#1  0x00626f71 in BPrivate::BPose::Draw () from /boot/system/lib/libtracker.so
#2  0x00648fe9 in BPrivate::BPoseView::DrawViewCommon ()
   from /boot/system/lib/libtracker.so
#3  0x00648ab7 in BPrivate::BPoseView::Draw ()
   from /boot/system/lib/libtracker.so
#4  0x003c19c4 in BView::_Draw () from /boot/system/lib/libbe.so
#5  0x003c7175 in BWindow::DispatchMessage () from /boot/system/lib/libbe.so
#6  0x003cb788 in BWindow::task_looper () from /boot/system/lib/libbe.so
#7  0x002efa4b in BLooper::_task0_ () from /boot/system/lib/libbe.so
#8  0x007216e3 in thread_entry () from /boot/system/lib/libroot.so
#9  0x78033fec in ?? ()
(gdb) 

Change History (3)

comment:1 by anevilyak, 7 years ago

Owner: changed from anevilyak to mmlr
Status: newassigned

Might be a missing bit somewhere in the typeahead filtering implementation, unless it's reproducible without it as well.

comment:2 by humdinger, 7 years ago

I've now played around some more, and it looks like the type-ahead filtering is essential to get it to crash.

comment:3 by humdinger, 9 months ago

Resolution: fixed
Status: assignedclosed

Cannot reproduce any longer. Fixed, I suppose.

Note: See TracTickets for help on using tickets.