Opened 8 years ago

Closed 20 months ago

Last modified 4 months ago

#9295 closed bug (fixed)

KDL while copy from/to USB disk

Reported by: dsjonny Owned by: nobody
Priority: normal Milestone: R1/beta2
Component: System/Kernel Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Platform: All

Description

I try to explain:

Sometimes I got a KDL while I copying something from/to USB disk. The most of the time when I use the Installer. If I initialize the target disk, I will have no problem, so maybe FS problem caused this (why?: if I want to "update" an already installed system with the latest image, I use the latest nightly anyboot image from USB disk. If I start the install process, at about 50% if I got a KDL, I reset the PC, and start it again, and got KDL again... So; if I initialize the target disk, the installation siccess.).

I have no idea what caused this, and I can provide only a photo, because I cannot use my keyboard in the KDL. And I cannot provide a Haiku version, because I meet this using Alpha/3/4/4.1, and I got this alert random, but I could make a photo only now. If I will got a similar alert, I will attach to the ticket too. The only same is the "vm_page_fault". I have already tried to disable the VM, but nothing cahnged.

I hope somebody will understand this.

Attachments (3)

SAM_0565.JPG (545.3 KB ) - added by dsjonny 8 years ago.
SAM_0571.JPG (540.8 KB ) - added by dsjonny 8 years ago.
Another vm_page_fault. Sorry for the quality.
SAM_0573.JPG (547.8 KB ) - added by dsjonny 8 years ago.
Another KDL. Sorry for the quality.

Download all attachments as: .zip

Change History (8)

by dsjonny, 8 years ago

Attachment: SAM_0565.JPG added

by dsjonny, 8 years ago

Attachment: SAM_0571.JPG added

Another vm_page_fault. Sorry for the quality.

by dsjonny, 8 years ago

Attachment: SAM_0573.JPG added

Another KDL. Sorry for the quality.

comment:1 by dsjonny, 8 years ago

I got another KDL. Using nightly 45122 image. What did I do:

  • git clone haiku-os
  • git clone webkit
  • play video

All these are from/to one USB HDD in the same time. There was no performance or any other problem. I got i3 CPU (4 core), 8GB RAM, SSD (where Haiku installed to).

I got only in the syslog:

KERN: bfs: Remove:2062: No such file or directory
KERN: bfs: Could not find value in index "size"!
KERN: bfs: Remove:2062: No such file or directory
KERN: bfs: Could not find value in index "last_modified"!

But I do not know it was at that time or not (no timestamp).

comment:2 by diver, 8 years ago

The last one is a dupe of #8345

comment:3 by axeld, 3 years ago

Owner: changed from axeld to nobody
Status: newassigned

comment:4 by waddlesplash, 20 months ago

Resolution: fixed
Status: assignedclosed

Fixed in hrev52646.

comment:5 by nielx, 4 months ago

Milestone: R1R1/beta2

Assign tickets with status=closed and resolution=fixed within the R1/beta2 development window to the R1/beta2 Milestone

Note: See TracTickets for help on using tickets.