Opened 13 years ago

Closed 13 years ago

#931 closed bug (fixed)

Installing MIME database doesn't work correctly on Ubuntu 6.10

Reported by: jackburton Owned by: jackburton
Priority: low Milestone: R1
Component: Build System Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by jackburton)

The step "Installing MIME database" of haiku build doesn't work correctly and produces some weird output on Ubuntu Edgy Eft.

This is the error message: build/scripts/build_haiku_image: 120: +: not found build/scripts/build_haiku_image: 120: +: not found Entry `generated/tmp/mime/mimedb18750_0.mime' is a directory. Command failed: Is a directory Command was:

cp :generated/tmp/mime/mimedb18750_0.mime

/myfs/home/config/settings/beos_mime/application/msword build/scripts/build_haiku_image: 120: +: not found resource(1, "META:TYPE") "application/msword"; resource(1, "META:TYPE") "application/ogg"; Entry `generated/tmp/mime/mimedb18750_0.mime' is a directory. Command failed: Is a directory Command was:

cp :generated/tmp/mime/mimedb18750_0.mime

/myfs/home/config/settings/beos_mime/application/ogg

The filetypes in the resulting images are also incorrectly set.

I think it could depend on the bash version. stefano@shiryu:~/haiku/haiku$ bash --version GNU bash, version 3.1.17(1)-release (i486-pc-linux-gnu) Copyright (C) 2005 Free Software Foundation, Inc.

Change History (8)

comment:1 Changed 13 years ago by jackburton

The following patch fixes the problem. I won't commit it because I'm not sure it works on previous bash versions.

comment:2 Changed 13 years ago by axeld

Out of curiosity, what does (( ... )) do? :-)

comment:3 in reply to:  2 ; Changed 13 years ago by jackburton

Replying to axeld:

Out of curiosity, what does (( ... )) do? :-)

Absolutely nothing :( In fact I just noticed this doesn't fix my problem. I just searched around for the specific problem and somewhere I read that for math operations you should use (( )). But as I said, this doesn't fix my problem.

comment:4 Changed 13 years ago by jackburton

Description: modified (diff)
Priority: normallow
Summary: Installing MIME database fails on Ubuntu Edgy EftInstalling MIME database produces weird output (but works) on Ubuntu 6.10

comment:5 in reply to:  3 Changed 13 years ago by jackburton

Replying to jackburton:

Apparently these warnings are harmless, and the boot problem I was having was related to another thing.

comment:6 Changed 13 years ago by jackburton

Description: modified (diff)
Summary: Installing MIME database produces weird output (but works) on Ubuntu 6.10Installing MIME database doesn't work correctly on Ubuntu 6.10

comment:7 in reply to:  6 Changed 13 years ago by jackburton

Owner: changed from bonefish to jackburton
Status: newassigned

Replying to jackburton:

Since rev 19344 building the database works under Edgy Eft too. The problem is that Edgy Eft symlinks /bin/sh to /bin/dash and dash doesn't contain many bash extensions like doing arithmetic operations inside [ ]. Output redirection to /dev/null doesn't work yet, though.

comment:8 Changed 13 years ago by jackburton

Resolution: fixed
Status: assignedclosed

Fixed in rev. 19345. &> is a bashism, not supported by dash (and sh)

Note: See TracTickets for help on using tickets.