Opened 12 years ago

Closed 11 years ago

#932 closed bug (fixed)

[Icons] White space behind desktop icon after icon view change

Reported by: jfreeman Owned by: aldeck
Priority: normal Milestone: R1
Component: Applications/Tracker Version: R1/pre-alpha1
Keywords: Cc: diver, jonas.kirilla
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Change the desktop's iconview to 64x64, and check the Show Disks Icon option in Tracker's settings.

There will be a white background around the Disks icon. Tested with revisions 19180 (BeOS-built) and 19193 (CentOS-built) under VMware.

Attachments (1)

icon problem.png (14.8 KB) - added by jfreeman 12 years ago.
Example screenshot

Download all attachments as: .zip

Change History (10)

Changed 12 years ago by jfreeman

Attachment: icon problem.png added

Example screenshot

comment:1 Changed 12 years ago by axeld

Owner: changed from axeld to stippi

comment:2 Changed 12 years ago by diver

Cc: diver added

comment:3 Changed 12 years ago by jonas.kirilla

Cc: jonas.kirilla added

comment:4 Changed 12 years ago by stippi

Component: - User Interface- Applications/Tracker

I tested this under QEMU. When I turn on "Show Disk Icon" in the Tracker settings, then change the Icon View size, the disk icon will just disappear. It will reappear when I toggle the Show Disk Icon option. I think this should be a Tracker bug. If I do the same thing in the apps folder for example, there is an old bitmap icon for CodyCam right now, and that one will be scaled and shown as expected. The app_server or the icon code does not know about the difference between the disk icon or any other icon, so I think it should be a Tracker bug.

comment:5 Changed 11 years ago by scottmc

Does this still happen for anyone else? I just checked it on hrev23287 and can't reproduce it. Although the Disks icon looks rather ugly at 64x64... but that's another bug.

comment:6 in reply to:  5 Changed 11 years ago by aldeck

Can't reproduce, seems fixed :)

comment:7 Changed 11 years ago by stippi

There is no white background anymore, but the bug is still there: If you have the Disk icon displayed and then change the icon size, the icon disappears. If you toggle the volume/disk icon mode, the icon will reappear with the correct scaling.

comment:8 in reply to:  7 Changed 11 years ago by aldeck

Owner: changed from stippi to aldeck
Status: newassigned

Replying to stippi:

There is no white background anymore, but the bug is still there: If you have the Disk icon displayed and then change the icon size, the icon disappears. If you toggle the volume/disk icon mode, the icon will reappear with the correct scaling.

I've got it fixed here! Indeed it's a Tracker bug. The bug is due to a different code path used when in icon mode with size other than 32 (unfinished?). To summarize, the Desktop PoseView gets litterally rebooted and changes are lost. Will commit soon :-)

comment:9 Changed 11 years ago by aldeck

Resolution: fixed
Status: assignedclosed

BTW as the initial bug is fixed it seems, i'll just close it to stop the confusion. Let's move on to #1833. #655 seems related too.

Note: See TracTickets for help on using tickets.