Opened 6 years ago

Closed 6 years ago

#9316 closed bug (fixed)

[cddb_daemon] creates wrong MIME internal-name for Title, Genre & Year

Reported by: ttcoder Owned by: nobody
Priority: normal Milestone: R1
Component: Servers Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

The cddb_daemon hardcodes e.g. "Audio:Title" which disagrees with the Haiku MIME database, which has "Media:Title".

Steps:

  • insert an audio CD
  • open the folder and create columns for all attributes

Expected behavior:

  • all the attributes should show up in Tracker

Actual behavior:

  • most do, but three do not, because Tracker expects internal-names for these that are different from those written by the cddb_daemon.

Indeed if you listattr /one/of/the/cdda/tracks

You'll get e.g.

..
        Text        13  "Audio:Title"
        Text         5  "Audio:Genre"
..

In Filetypes, audio title is configured with internal name Media:Title (not Audio:Title as used by cddb_daemon), and same for Media:Genre and Media:Year.

Change History (1)

comment:1 Changed 6 years ago by humdinger

Resolution: fixed
Status: newclosed

Fixed with hrev45085. Thanks!

Note: See TracTickets for help on using tickets.