Opened 7 years ago

Closed 7 years ago

#9368 closed bug (fixed)

KDL on boot, caused by ipro1000 driver

Reported by: Giova84 Owned by: korli
Priority: normal Milestone: R1
Component: Drivers/Network/ipro1000 Version: R1/Development
Keywords: KDL on boot, caused by ipro1000 driver Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

hrev45142

When i boot Haiku, after the last icon (the rocket) every time a KDL appear, about net_server and ipro1000 network driver. I type "es" to exit from KDL, to normally continue on boot. Then, in Haiku i have no issue with my eth card (ipro1000): works fine as usual.

Screenshot attached.

Attachments (1)

KDL.jpg (260.3 KB ) - added by Giova84 7 years ago.

Download all attachments as: .zip

Change History (10)

by Giova84, 7 years ago

Attachment: KDL.jpg added

comment:1 by Giova84, 7 years ago

Component: Drivers/Network/ipro1000Servers/net_server
Owner: changed from nobody to axeld

comment:2 by anevilyak, 7 years ago

Component: Servers/net_serverDrivers/Network/ipro1000
Owner: changed from axeld to korli
Status: newassigned

comment:3 by korli, 7 years ago

should be fixed in hrev45146

comment:4 by korli, 7 years ago

actually hrev45147 ..

in reply to:  4 comment:5 by Giova84, 7 years ago

Replying to korli:

actually hrev45147 ..

Hi Korli,

since i don't have skills to build Haiku by myself, and due to the fact that hrev45147 is not still available for download on haiku-files.org, can you send me the newer version of ipro1000 driver, so i can test and eventually confirm to you the fix?

comment:6 by umccullough, 7 years ago

If you wait a couple more hours, the nightly builder script will likely have run and uploaded a fresh build for you.

I believe it runs at midnight EST (UTC-5) - and probably takes an hour or so to complete.

comment:7 by korli, 7 years ago

hrev45148 nightly is now available (at least x86 GCC 2 Hybrid)

in reply to:  7 comment:8 by Giova84, 7 years ago

Replying to korli:

hrev45148 nightly is now available (at least x86 GCC 2 Hybrid)

I am on hrev45148 and i can confirm the fix! Great job.

comment:9 by korli, 7 years ago

Resolution: fixed
Status: assignedclosed

Nice, thanks for the feedback!

Note: See TracTickets for help on using tickets.