Opened 7 years ago

Closed 4 years ago

#9375 closed enhancement (fixed)

Sync ffmpeg to version 1.0

Reported by: jackburton Owned by: pulkomandy
Priority: low Milestone: Unscheduled
Component: Audio & Video/Codecs Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I think we should sync ffmpeg to version 1.0 (and stay with it for some time, since it's a stable version).

Change History (9)

comment:1 by korli, 7 years ago

or 1.1

comment:2 by diver, 5 years ago

Component: - GeneralAudio & Video/Codecs

or 2.4 :)

comment:3 by pulkomandy, 5 years ago

Milestone: R1Unscheduled

Unfortunately anything later than 0.10 crashes when decoding video in a gcc2 build. So we'll have to stay with that old rusty version for now.

comment:4 by jackburton, 5 years ago

Would it be possible to use the old version only for gcc2, and the new one for gcc4 ?

comment:5 by pulkomandy, 5 years ago

Yes, but the ffmpeg media plugin will need to be duplicated as it's unlikely that a subset of APIs common to 0.10 and 2.4 can be found. There are enough problems with the ffmpeg add-on currently to not add this to the mix, I think, and there is not much to be gained currently. The 0.10 branch was maintained until last month, and while it has an old API, the core (including support for various video and audio codecs) was kept up to date.

comment:6 by diver, 4 years ago

Owner: changed from nobody to pulkomandy
Status: newassigned

Is it possible now after hrev49603?

comment:7 by pulkomandy, 4 years ago

Our problems with different APIs are solved now, so we can start using 2.4 once there is a package for it (and after a good run of testing) at least for gcc4. Since there still are updates to the 0.10 branch as well, there is little need to update to 1.x for the gcc2 branch. Going with 0.11 or later is possible but only if we disable assembler code apparently (I tested this on 0.11 and confirmed it works for decoding videos in h264, where the 0.11 with asm code is known to crash and complain loudly).

So, all we need now is updated packages.

comment:8 by diver, 4 years ago

This seems to be resolved now, does it?

comment:9 by pulkomandy, 4 years ago

Resolution: fixed
Status: assignedclosed

Yes, fixed as much as reasonably possible in hrev49802.

Note: See TracTickets for help on using tickets.