Opened 15 months ago

Closed 4 months ago

#9417 closed bug (fixed)

Path names are translated in German user guide

Reported by: mks Owned by: humdinger
Priority: normal Milestone: R1
Component: Documentation Version: R1/alpha4.1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

E.g. on http://www.haiku-os.org/docs/userguide/de/applications/activitymonitor.html

The path to the settings is translated:

~/Konfiguration/settings/ActivityMonitor

should be

~/config/settings/ActivityMonitor

Not only Activity Monitor, but at least all the applications are effected, perhaps other pages.

Change History (3)

comment:1 Changed 15 months ago by anevilyak

  • Component changed from - General to Documentation
  • Owner changed from nobody to humdinger
  • Status changed from new to assigned

comment:2 Changed 15 months ago by humdinger

Not a bug, a feature. :)
When Haiku got the option to show translated application names and certain paths, we decided to use these in the userguide. There's still the original path/app name in a tool tip if you hover the mouse over it. For alpha4 this option has been disabled in the Locale preferences, because there's a bug in IIRC the runtime loader.

I'm not sure localization of paths and maybe also app names is actually a good idea... There are some difficult issues, think shell, remote access, scripts, performance concerns...

Anyway, we'll leave it as is now and see where this is going for beta/R1.
I'll leave the ticket open as reminder.

comment:3 Changed 4 months ago by humdinger

  • Resolution set to fixed
  • Status changed from assigned to closed

On our haiku-i18n-de mailinglist, we decided to revert the path translation in the user guide. The translation for application names is still there, as those make more sense. Think preference panel, for example. I'm pretty sure those will eventually work when R1 hits.

Note: See TracTickets for help on using tickets.