Opened 7 years ago

Closed 7 years ago

#9455 closed bug (duplicate)

KDL caused by kernel_x86, libbe.so, or libroot.so

Reported by: Robert S. Owned by: axeld
Priority: high Milestone: R1
Component: System/Kernel Version: R1/Development
Keywords: libbe.so kernel libroot.so Cc:
Blocked By: #8979 Blocking:
Has a Patch: no Platform: x86

Description (last modified by axeld)

Hi,

i got the following KDL. So far I see and unstand it is caused by libbe.so or the Haiku-OS kernel.

stack trace for thread 199 "w:124:/boot/home/Desktop"
    kernel stack: 0x81baf000 to 0x81bb3000
      user stack: 0x7067c000 to 0x706bc000
frame               caller     <image>:function + offset
0 81bb2b58 (+  48) 80095238   <kernel_x86> invoke_command_trampoline( [34m0x81bb2bf0 [0m) + 0x1c
1 81bb2b88 (+  12) 80123f32   <kernel_x86> arch_debug_call_with_fault_handler + 0x1b
2 81bb2b94 (+  48) 800941b2   <kernel_x86> debug_call_with_fault_handler + 0x5e
3 81bb2bc4 (+  64) 80095491   <kernel_x86> invoke_debugger_command + 0xb9
4 81bb2c04 (+  64) 800952bd   <kernel_x86> invoke_pipe_segment(debugger_command_pipe*: [34m0xcce38030 [0m, int32: [34m0 [0m, [34m0x0 [0m [31m"<NULL>" [0m) + 0x79
5 81bb2c44 (+  64) 800955fc   <kernel_x86> invoke_debugger_command_pipe + 0x9c
6 81bb2c84 (+  48) 80097298   <kernel_x86> ExpressionParser< [32m0x81bb2d34 [0m>::_ParseCommandPipe( [34m0x81bb2d30 [0m) + 0x234
7 81bb2cb4 (+  64) 800964b8   <kernel_x86> ExpressionParser< [32m0x81bb2d34 [0m>::EvaluateCommand( [34m0x801a2f60 [0m [36m"sc | qrappend" [0m, [34m0x81bb2d30 [0m) + 0x2d0
8 81bb2cf4 (+ 224) 800988e4   <kernel_x86> evaluate_debug_command + 0x80
9 81bb2dd4 (+  64) 80092a3e   <kernel_x86> kernel_debugger_loop( [34m0x801700f7 [0m [36m"PANIC: " [0m, [34m0x80152064 [0m [36m"port %ld: no messages found
" [0m, [34m0x81bb2e80 [0m [36m"� " [0m, int32: [34m3 [0m) + 0x32a
10 81bb2e14 (+  48) 80092c93   <kernel_x86> kernel_debugger_internal( [34m0x801700f7 [0m [36m"PANIC: " [0m, [34m0x80152064 [0m [36m"port %ld: no messages found
" [0m, [34m0x81bb2e80 [0m [36m"� " [0m, int32: [34m3 [0m) + 0x53
11 81bb2e44 (+  48) 8009453e   <kernel_x86> panic + 0x36
12 81bb2e74 (+  80) 800634d4   <kernel_x86> _get_port_message_info_etc + 0x2ac
13 81bb2ec4 (+  80) 80063219   <kernel_x86> port_buffer_size_etc + 0x25
14 81bb2f14 (+  48) 800643c9   <kernel_x86> _user_port_buffer_size_etc + 0x8d
15 81bb2f44 (+ 100) 80126bd0   <kernel_x86> handle_syscall + 0xcd
user iframe at 0x81bb2fa8 (end = 0x81bb3000)
eax 0xd4          ebx 0x98c8e8       ecx 0x706bbe30  edx 0xffff0114
esi 0xffffffff    edi 0x7fffffff     ebp 0x706bbe5c  esp 0x81bb2fdc
eip 0xffff0114 eflags 0x3216    user esp 0x706bbe30
vector: 0x63, error code: 0x0
16 81bb2fa8 (+   0) ffff0114   <commpage> commpage_syscall + 0x04
17 706bbe5c (+  48) 00491b45   <libbe.so> BPrivate::LinkReceiver< [32m0x186d5a38 [0m>::AdjustReplyBuffer(int64: [34m9223372036854775807 [0m) + 0x45
18 706bbe8c (+  64) 00491c07   <libbe.so> BPrivate::LinkReceiver< [32m0x186d5a38 [0m>::ReadFromPort(int64: [34m9223372036854775807 [0m) + 0x3b
19 706bbecc (+  48) 004919eb   <libbe.so> BPrivate::LinkReceiver< [32m0x186d5a38 [0m>::GetNextMessage( [34m0x706bbf44 [0m, int64: [34m9223372036854775807 [0m) + 0x47
20 706bbefc (+ 128) 002a2c70   <_APP_> ServerWindow< [32m0x186d36d8 [0m>::_MessageLooper( [34m0x0 [0m) + 0x2fc
21 706bbf7c (+  48) 0027f668   <_APP_> MessageLooper< [32m0x186d36d8 [0m>::_message_thread(NULL) + 0x28
22 706bbfac (+  48) 008e7893   <libroot.so> _get_next_team_info (nearest) + 0x5f
23 706bbfdc (+   0) 706bbfec   4713:w:124:TrackerWindow_199_stack@0x70678000 + 0x43fec

Change History (1)

comment:1 by axeld, 7 years ago

Blocked By: 8979 added
Description: modified (diff)
Resolution: duplicate
Status: newclosed

Please look out for older tickets. This one is a duplicate of #8979 that you reported a few months ago :-)

Also, please always include the original KDL message. If it is scrolled out of sight, you can use the message command to let KDL print it again.

Note: See TracTickets for help on using tickets.