Opened 7 years ago

Last modified 7 years ago

#9467 reopened bug

Focus of windows is stolen

Reported by: Giova84 Owned by: axeld
Priority: normal Milestone: R1
Component: Applications/Tracker Version: R1/Development
Keywords: Focus of windows is stolen Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

Since hrev45280 i have found a strange behaviour about focus. The first thing is: if in an application a tooltip appears, this tooltip will steal focus to application and you have to click with mouse in app window to take again the focus. second: if inside /system folder you attempt to rename a file, obviously as usual, an alert prompt you about. You click on rename and then the Tracker window will lost the focus and made impossible to rename the file, because the text field for renaming file is present only in focused windows. To be more clear i made a little video (attached) of this.

Attachments (1)

Focus_stolen.ogg (771.5 KB ) - added by Giova84 7 years ago.

Download all attachments as: .zip

Change History (5)

by Giova84, 7 years ago

Attachment: Focus_stolen.ogg added

comment:1 by Giova84, 7 years ago

This also occurs when you delete any file on your system: the alert window will steal focus to Tracker's window.

comment:2 by Giova84, 7 years ago

This was a really silly issue: on my Desktop there was a clock, which i have set on top using "hey". Now i have a regular focus :-)

This ticket can be cose as invalid.

comment:3 by leavengood, 7 years ago

Resolution: invalid
Status: newclosed

comment:4 by diver, 7 years ago

Resolution: invalid
Status: closedreopened

I've just ran into the same problem, can't reproduce it yet, though.

Note: See TracTickets for help on using tickets.