Opened 7 years ago

Closed 6 years ago

Last modified 6 years ago

#9475 closed bug (fixed)

Sony Z1 XMP boot failure

Reported by: vercu Owned by: pdziepak
Priority: normal Milestone: R1
Component: Drivers/Power Version: R1/Development
Keywords: cpu_idle Cc: kevinjamesfield@…
Blocked By: Blocking: #9614
Has a Patch: no Platform: x86

Description

My Centrino Notebook Sony Z1 XMP does not boot with haiku-nightly-hrev45316-x86gcc2hybrid-cd. It went to KDL. Screenshot enclosed. This notebook is fully supported by Haiku. The last working revision i tested was haiku-nightly-hrev45234-x86gcc2hybrid-cd. Cpuidle was enabled between these revisions and cpuidle is mentioned in the KDL so maybe this could be the problem.

Attachments (6)

Sony_z1xmp-noboot-1.jpg (173.4 KB ) - added by vercu 7 years ago.
Sony_z1xmp-noboot
Sony_z1xmp-noboot-2.jpg (151.5 KB ) - added by vercu 7 years ago.
Sony_z1xmp-noboot
listimage 1.pdf (29.3 KB ) - added by vercu 7 years ago.
Report-1.htm (196.0 KB ) - added by vercu 7 years ago.
listimage 1 (7.6 KB ) - added by vercu 6 years ago.
from 2014-02-26
syslog (173.8 KB ) - added by vercu 6 years ago.
from 2014-02-26

Download all attachments as: .zip

Change History (21)

by vercu, 7 years ago

Attachment: Sony_z1xmp-noboot-1.jpg added

Sony_z1xmp-noboot

by vercu, 7 years ago

Attachment: Sony_z1xmp-noboot-2.jpg added

Sony_z1xmp-noboot

comment:1 by diver, 7 years ago

Component: - GeneralDrivers/Power
Owner: changed from nobody to yongcong

Indeed.

comment:2 by mmadia, 7 years ago

Could you provide additional information about your hardware -- possibly even the exact model of your CPU?

by vercu, 7 years ago

Attachment: listimage 1.pdf added

by vercu, 7 years ago

Attachment: Report-1.htm added

comment:3 by vercu, 7 years ago

listimage 1 an a hardware report is enclosed.

comment:4 by vercu, 7 years ago

Tested haiku-nightly-hrev45287-x86gcc2hybrid-cd on this notebook and everything works without a problem.

comment:5 by vercu, 7 years ago

Tested haiku-nightly-hrev45301-x86gcc2hybrid-cd and it is not working. All boot symbols light on and then KDL.

comment:6 by diver, 6 years ago

Keywords: cpu_idle added

comment:7 by diver, 6 years ago

Blocking: 9614 added

comment:8 by Kev, 6 years ago

Cc: kevinjamesfield@… added

comment:9 by diver, 6 years ago

Owner: changed from yongcong to pdziepak
Status: newassigned

Is this still an issue? There were some fixes to this driver in hrev46690 http://cgit.haiku-os.org/haiku/commit/?id=7db89e

comment:10 by vercu, 6 years ago

hrev46706 is now on this notebook. It works flawlessly. Is the cpuidle driver enabled in this build? How can i check this?

comment:11 by diver, 6 years ago

Try grep cpu /var/log/syslog and/or listimage | grep cpu.

comment:12 by humdinger, 6 years ago

Resolution: fixed
Status: assignedclosed

Have a look at Paweł's comment to his article. In the middle of paragraph four, he mentions the currently supported CPUs.
Since things are working for you, I guess I can close this ticket.

by vercu, 6 years ago

Attachment: listimage 1 added

from 2014-02-26

by vercu, 6 years ago

Attachment: syslog added

from 2014-02-26

comment:13 by vercu, 6 years ago

i will install the newest revision and report back.

comment:14 by diver, 6 years ago

Your syslog is useless as it is flooded by atheroswifi driver.

comment:15 by vercu, 6 years ago

hrev46924 is now installed and it works without a problem. Thank you very much Pawel and all others involved for fixing this.

Note: See TracTickets for help on using tickets.