Opened 8 years ago

Closed 5 years ago

#9488 closed bug (fixed)

Recognizes tooltips as "active window"

Reported by: mmadia Owned by: nobody
Priority: normal Milestone: R1
Component: Applications/Screenshot Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Platform: All

Description

hrev45285.

If a tooltip appears in the currently active window, Screenshot take an image of the tooltip for "Capture active window". The expected behavior is for Screenshot to ignore tooltips as an active window.

Change History (3)

comment:1 by leavengood, 8 years ago

This could be tricky to fix, since the tool tip window does not have any guaranteed way to identify that it is a tool tip window. About the only thing I could think of is that its internal name is "tool tip" and maybe Screenshot could look for that. Otherwise we might need to add a window flag B_TOOLTIP or something, which could then be checked for.

comment:2 by jscipione, 5 years ago

This appears to be fixed now

Guessing it was fixed in hrev49458 specifically b2a0b6323e67

comment:3 by jscipione, 5 years ago

Resolution: fixed
Status: newclosed

Scratch that, fixed in hrev50178

Note: See TracTickets for help on using tickets.