Opened 7 years ago

Closed 5 years ago

#9495 closed bug (invalid)

"jam @target update file" no longer works correctly

Reported by: leavengood Owned by: bonefish
Priority: normal Milestone: R1
Component: Build System Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

When I want to update specific parts of the system in a VMware image, I usually use something like:

jam -q -j8 @vmware update libbe.so

But right now I have to give this command twice for it to work. If I just do it once, the target is just deleted from the image, not updated. In the case of libbe.so, this makes the system unbootable, which is annoying. It took me a bit to figure out what was going on in that case.

Change History (2)

comment:1 by bonefish, 6 years ago

I've never encountered this problem and I use that method all the time. Can you still reproduce it?

comment:2 by waddlesplash, 5 years ago

Resolution: invalid
Status: newclosed

No response. Works for me.

Note: See TracTickets for help on using tickets.