Opened 6 years ago

Last modified 4 years ago

#9537 new bug

[VirtualMemory] interface is confusing

Reported by: diver Owned by: kallisti5
Priority: normal Milestone: R1
Component: Preferences/VirtualMemory Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

It's not clear what this progress bar shows. Is it current swap file usage or something else? Quite confusing :-/

Also Automatic swap management could be renamed to Automatic swap size management and put below the volume selector. This way you'll be able to select different volume for the swap file and don't bother with it's size.

Maximum swap size can be made larger than free space?

Attachments (1)

VirtualMemory.png (24.5 KB ) - added by diver 6 years ago.

Download all attachments as: .zip

Change History (4)

by diver, 6 years ago

Attachment: VirtualMemory.png added

comment:1 by kallisti5, 6 years ago

"current swap" shows the currently used swap / total swapfile size.

The maximum range on the "Requested swap file size" is the space available on the target swap disk.

-1 moving the automatic swap management below the drive selector. Automatic means that the OS determines the size and location of the swap file. Manual means the end user selects the size and location of the swap file. If you want the gui to change, patches welcome :)

comment:2 by pulkomandy, 5 years ago

The computation for the maximal allowed size is "free space + current swap size", which is why it allows more than the currently free space on disk.

comment:3 by diver, 4 years ago

Ran into this problem again while trying to compile openjdk in a VM. I had to increase swap size to make compilation it not crash during compilation as I didn't have enough free space on /boot since the anyboot image has only so much space.

So I changed volume for the swap thinking that VirtualMemory would be smart enough to create a swap file with reasonable size. I rebooted, tried to compile openjdk again and got into the same error with not enough virtual memory. Preflet showed 50Mb on my /data partition.

Note: See TracTickets for help on using tickets.