Opened 13 years ago

Closed 4 years ago

#96 closed bug (fixed)

Chart test app display bug

Reported by: rune.hatle@… Owned by: jackburton
Priority: normal Milestone: R1
Component: Applications/Chart Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by jackburton)

i have an ati radeon 9700 pro and the "chart" program works fine. exept 1 thing. when i shift from directwindow and drawbitmap it hangs som of the "dots" on the window

Change History (20)

comment:1 Changed 13 years ago by korli

Summary: chartChart test app display bug

comment:2 Changed 13 years ago by jackburton

Fixed by Axel in svn

comment:3 Changed 13 years ago by johndrinkwater

Cc: john@… added

This is still an open bug in hrev16324, stars are left on the BDirectWindow from the first frame after changing display mode.

comment:4 Changed 13 years ago by sikosis

Status: newassigned

comment:5 Changed 13 years ago by sikosis

Status: assignednew

comment:6 Changed 13 years ago by sikosis

Owner: changed from sikosis to jackburton

comment:7 Changed 13 years ago by jackburton

Status: newassigned

comment:8 Changed 13 years ago by jackburton

"after changing display mode"

You mean after switching from directwindow to drawbitmap and back or after switching display mode like from 800x600 to 1024x768 ?

comment:9 Changed 13 years ago by jackburton

Okay, I could reproduce it in 32 bit mode. Seems something like #111. Will have a look.

comment:10 Changed 13 years ago by axeld

Does this still happen?

comment:11 Changed 13 years ago by johndrinkwater

Yup, just tested with hrev17004

This is caused when changing drawing mode (drawbitmap/directwindow), the view isn?t invalidated correctly from the previous frame.

comment:12 Changed 13 years ago by diver

Cc: diver added

comment:13 Changed 13 years ago by korli

bug_group: developers

comment:14 Changed 13 years ago by kutspam@…

Also in 17782 this bug appears

comment:15 Changed 13 years ago by kutspam@…

(In reply to comment #7)

Also in 17782 this bug appears

And the cursor gets eaten away. I have the radeon driver working so there should be HW accel. BDirectWindow used

comment:16 Changed 13 years ago by jackburton

(In reply to comment #8)

(In reply to comment #7)

Also in 17782 this bug appears

And the cursor gets eaten away. I have the radeon driver working so there should be HW accel. BDirectWindow used

Currently we don't have an hardware cursor, so that is expected, actually :) Thanks for reporting, though.

comment:17 Changed 11 years ago by jackburton

Description: modified (diff)
Platform: All
Resolution: fixed
Status: assignedclosed

Since a "couple" of revisions (hrev15844 actually) the animation view was placed off by one. Fixed in hrev23059.

comment:18 Changed 7 years ago by caimbeul

Resolution: fixed
Status: closedreopened
Version: R1/alpha3

I have what appears to be this same error, in R1/alpha3 and in hrev43768 (gcc2hybrid, VirtualBox 4.1.6 on Windows XP SP3).

Steps to reproduce:

  1. Open the Chart Demo.
  2. Set Display to DrawBitmap.
  3. Now set Display to DirectWindow.
  4. Set Animation to e.g. Slow Rotation.
  5. Drag the Chart window around while the animation runs.

Result:

The initial star layout, from before the animation started, is overlaid on top of the animated stars. These "frozen" stars are erased one by one as the animated stars pass through them, but dragging the window causes them all to reappear.

Expected:

The animation should continue undisturbed as the window is dragged.

Note that this only happens if DrawBitmap is selected before switching to DirectWindow. If I set Display to DirectWindow immediately after starting the program, there is no problem.

comment:19 Changed 6 years ago by diver

Cc: diver removed
Component: ApplicationsApplications/Chart
Version: R1/alpha3R1/Development

Still here in hrev44622.

comment:20 Changed 4 years ago by pulkomandy

Resolution: fixed
Status: reopenedclosed

Fixed in hrev48023.

Note: See TracTickets for help on using tickets.