Opened 6 years ago

Closed 6 years ago

#9631 closed bug (duplicate)

Mouse cursor disappears temporarily and returns permanently changed

Reported by: Kev Owned by: euan
Priority: normal Milestone: R1
Component: Servers/app_server Version: R1/Development
Keywords: Cc:
Blocked By: #9261 Blocking:
Has a Patch: no Platform: x86

Description

...to a plus sign. Oddly, taking a screenshot "with cursor" shows a normal cursor.

hrev45444 gcc4hybrid.

Change History (8)

comment:1 Changed 6 years ago by Kev

I should clarify. By "permanently" I mean even after GP closes, and until the next reboot.

comment:2 Changed 6 years ago by anevilyak

Out of curiosity, what graphics card do you have in that machine?

comment:3 Changed 6 years ago by Kev

Radeon 9200 128 MB AGP, is that bad? :-)

comment:4 Changed 6 years ago by anevilyak

Component: ApplicationsDrivers/Graphics/radeon
Owner: changed from nobody to euan

No, I've just seen similar problems with the cursor in general on the same driver myself since hardware cursor support was enabled.

comment:5 Changed 6 years ago by Kev

Summary: Gobe Productive 2.01 Spreadsheet permanently changes mouse cursorMouse cursor disappears temporarily and returns permanently changed

This was originally with Gobe Productive 2.01 Spreadsheet, but now I have it in BePDF also (installed with installoptionalpackage.) As soon as I launch BePDF, my cursor is completely invisible, until I close BePDF, at which time it turns into a white block with a black hand. (With Gobe it turns into various things, two examples I remember are a spreadsheet cell "+ sign" and a resize arrow.) With BePDF, subsequent launches do not cause the cursor to disappear, but it never returns to a normal cursor, either.

comment:6 Changed 6 years ago by Kev

Also on hrev45484 gcc4hybrid, BTW.

comment:7 Changed 6 years ago by anevilyak

Radeon's cursor acceleration hooks have been disabled in hrev45508. Leaving ticket open until they're actually fixed properly though.

comment:8 Changed 6 years ago by anevilyak

Blocked By: 9261 added
Component: Drivers/Graphics/radeonServers/app_server
Resolution: duplicate
Status: newclosed

Duplicate of #9261.

Note: See TracTickets for help on using tickets.