Opened 6 years ago

Last modified 6 years ago

#9635 new bug

After closing GLTeapot, image stays behind, but can be erased with mouseover

Reported by: Kev Owned by: kallisti5
Priority: normal Milestone: R1
Component: Applications/GLTeapot Version: R1/Development
Keywords: Cc:
Blocked By: Blocking: #9805
Has a Patch: no Platform: x86

Description

This may or may not be related to:

https://dev.haiku-os.org/ticket/1355#comment:7

...since Alt+W there was reported as OK, and that's how I typically close windows, but it's possible I clicked the yellow tab square to close this one time. I can't reproduce it. First thing I launched after a cold boot.

Radeon 9200 128 MB AGP on hrev45453 gcc4hybrid.

Attachments (1)

glteapot leftovers.png (40.8 KB) - added by Kev 6 years ago.

Download all attachments as: .zip

Change History (8)

Changed 6 years ago by Kev

Attachment: glteapot leftovers.png added

comment:1 Changed 6 years ago by kallisti5

I think i've seen this a few times. I'm not 100% sold though that it is GLTeapot's fault. I've seen the same corruption in other non GL applications.

comment:2 Changed 6 years ago by Kev

Maybe the app_server? Have you seen it on the Desktop only, like me, or pasted onto other apps too? (If it's only the Desktop, maybe it's possible it's Tracker?)

comment:3 Changed 6 years ago by phoudoin

Looks like when a window with transparent color view is closed, it doesn't always invalidate the area behind it, leaving the (directmode) content.

comment:4 Changed 6 years ago by diver

Blocking: 9805 added

comment:5 Changed 6 years ago by Kev

Still can't reproduce it trying on hrev46198.

comment:6 Changed 6 years ago by diver

Still here, you just need to try a bit harder now :-)

comment:7 Changed 6 years ago by diver

...using Alt+q, that is.

Note: See TracTickets for help on using tickets.