Opened 7 years ago

Closed 7 weeks ago

#9635 closed bug (duplicate)

After closing GLTeapot, image stays behind, but can be erased with mouseover

Reported by: Kev Owned by: kallisti5
Priority: normal Milestone: R1
Component: Applications/GLTeapot Version: R1/Development
Keywords: Cc:
Blocked By: #6614 Blocking: #9805
Platform: x86

Description

This may or may not be related to:

https://dev.haiku-os.org/ticket/1355#comment:7

...since Alt+W there was reported as OK, and that's how I typically close windows, but it's possible I clicked the yellow tab square to close this one time. I can't reproduce it. First thing I launched after a cold boot.

Radeon 9200 128 MB AGP on hrev45453 gcc4hybrid.

Attachments (1)

glteapot leftovers.png (40.8 KB ) - added by Kev 7 years ago.

Download all attachments as: .zip

Change History (9)

by Kev, 7 years ago

Attachment: glteapot leftovers.png added

comment:1 by kallisti5, 7 years ago

I think i've seen this a few times. I'm not 100% sold though that it is GLTeapot's fault. I've seen the same corruption in other non GL applications.

comment:2 by Kev, 7 years ago

Maybe the app_server? Have you seen it on the Desktop only, like me, or pasted onto other apps too? (If it's only the Desktop, maybe it's possible it's Tracker?)

comment:3 by phoudoin, 7 years ago

Looks like when a window with transparent color view is closed, it doesn't always invalidate the area behind it, leaving the (directmode) content.

comment:4 by diver, 7 years ago

Blocking: 9805 added

comment:5 by Kev, 7 years ago

Still can't reproduce it trying on hrev46198.

comment:6 by diver, 7 years ago

Still here, you just need to try a bit harder now :-)

comment:7 by diver, 7 years ago

...using Alt+q, that is.

comment:8 by pulkomandy, 7 weeks ago

Blocked By: 6614 added
Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.