Opened 6 years ago

Closed 5 years ago

#9718 closed bug (fixed)

KERN: More than 99% interrupts of vector 16 are unhandled

Reported by: jessicah Owned by: korli
Priority: normal Milestone: R1
Component: Drivers/Graphics/intel_extreme Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Possibly related to #3008. Brand new build of an IvyBridge system. Syslog attached.

System starts up, goes through the lil icons stuff. After the rocket, screen turns off/goes to sleep, and unresponsive.

Attachments (1)

syslog.txt (116.3 KB) - added by jessicah 6 years ago.

Download all attachments as: .zip

Change History (5)

Changed 6 years ago by jessicah

Attachment: syslog.txt added

comment:1 Changed 6 years ago by mmlr

Component: System/KernelDrivers/Graphics/intel_extreme

Reading the routing table there are 5 devices on GSI 16:

pci 0:20:0: 7 Series/C210 Series Chipset Family USB xHCI Host Controller

The xHCI driver is incomplete and not loaded, so that one shouldn't be a problem.

pci 0:26:0: 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2

EHCI is loaded relatively early and the first message is pretty far away from that, so this one is less likely to blame.

pci 0:22:0: 7 Series/C210 Series Chipset Family MEI Controller #1

There's no driver for MEI controllers and no interrupts should be enabled for it.

pci 0:28:0: 7 Series/C210 Series Chipset Family PCI Express Root Port 1

There doesn't seem to be anything attached to the PCIe port, so it shouldn't generate interrupts.

pci 0:2:0: Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller

The first message shows up relatively soon after the following is printed:

KERN: intel_extreme: intel_extreme_init: completed successfully!

This line is output just after the interrupt is configured at the end of the intel_extreme_init function. So it looks like the problem is in the interrupt handler of the intel_extreme driver.

The interrupt routing itself looks fine. And since we do get the message for vector 16, it also looks like the right GSI is routed.

You could verify that by forcing safe mode video in the boot menu and/or removing the intel_extreme driver from "/boot/system/add-ons/kernel/drivers/bin".

comment:2 Changed 6 years ago by jessicah

I removed the intel_extreme driver, and Haiku boots to the desktop! I wonder if it's struggling with the multiple outputs of the graphics chip. I also noticed in the syslog that it wanted to choose 1024x768 as the resolution. This has DisplayPort, HDMI & DVI (think it's digital only), and at boot I am able to choose 1920x1080 as the resolution (although syslog still showed choosing 1024x768). Currently using HDMI, although DVI didn't work either when I had a DVI monitor connected.

comment:3 Changed 5 years ago by korli

Owner: changed from axeld to korli
Status: newassigned

comment:4 Changed 5 years ago by korli

Resolution: fixed
Status: assignedclosed

Should be fixed in hrev47032. Please reopen if needed.

Note: See TracTickets for help on using tickets.