Opened 6 years ago

Closed 6 years ago

#9724 closed bug (fixed)

BPopUpMenu positioned incorrectly based on the location of the marked submenu item

Reported by: jscipione Owned by: axeld
Priority: normal Milestone: R1
Component: Kits/Interface Kit Version: R1/alpha4.1
Keywords: Cc:
Blocked By: Blocking: #9725
Has a Patch: yes Platform: All

Description

This problem was noticed in the layout-converted Find Panel, but, it seems to be a bug in BPopUpMenu or a menu class as far as I can tell. The menu location seems to be positioned based on the marked item, even if that item is in a submenu. If the submenu is very tall and the marked item is found down the list it pushes the menu to the top of the screen even though the menu is smaller.

Attachments (2)

BPopUpMenu Bug.png (83.0 KB) - added by jscipione 6 years ago.
Screenshot showing the bug, seems to be caused by the position of the marked submenu item
0001-Fix-positioning-of-BPopUpMenu-when-a-nested-item-is-.patch (912 bytes) - added by jessicah 6 years ago.

Download all attachments as: .zip

Change History (10)

Changed 6 years ago by jscipione

Attachment: BPopUpMenu Bug.png added

Screenshot showing the bug, seems to be caused by the position of the marked submenu item

comment:1 Changed 6 years ago by jscipione

Also note that radio mode is set to false for this BPopUpMenu so it really shouldn't be considering the location of the marked item at all, maybe BPopUpMenu is assumed to be in radio mode somewhere it shouldn't?

comment:2 Changed 6 years ago by anevilyak

Blocking: 9725 added

comment:3 Changed 6 years ago by jessicah

Has a Patch: set

comment:4 Changed 6 years ago by jessicah

Has a Patch: unset

comment:5 Changed 6 years ago by jessicah

Has a Patch: set

comment:6 Changed 6 years ago by jessicah

Updated patch attached (incorrectly refactored it the first time...)

comment:7 Changed 6 years ago by jessicah

Okay, finally got this patch created properly...

comment:8 Changed 6 years ago by jscipione

Resolution: fixed
Status: newclosed

Fixed in hrev45599

Note: See TracTickets for help on using tickets.