Opened 6 years ago

Last modified 3 months ago

#9728 reopened bug

WebPositive: missing text-shadow, box-shadow support, broken border-radius support

Reported by: dsjonny Owned by: leavengood
Priority: normal Milestone: R1
Component: Applications/WebPositive Version: R1/Development
Keywords: Cc:
Blocked By: #7407 Blocking:
Has a Patch: no Platform: All

Description

There are some CSS properties are missing: text-shadow box-shadow

And the border*radius looks wrong.

In InternetExplorer:

In WebPositive:

Attachments (2)

ie.png (163.1 KB) - added by dsjonny 6 years ago.
webpositive.png (95.1 KB) - added by dsjonny 6 years ago.

Download all attachments as: .zip

Change History (10)

Changed 6 years ago by dsjonny

Attachment: ie.png added

Changed 6 years ago by dsjonny

Attachment: webpositive.png added

comment:1 Changed 6 years ago by dsjonny

The "fieldset" border is still wrong (the label is striked out): No image "webpositive2.png" attached to Ticket #9728

Last edited 6 years ago by dsjonny (previous) (diff)

comment:2 Changed 6 years ago by anevilyak

Blocked By: 7407 added

The box-shadow issue problems are already tracked in ticket #7407.

comment:3 Changed 6 years ago by diver

Should this one be closed as a dupe of #7407 then?

comment:4 Changed 5 years ago by pulkomandy

Summary: WebPositive: missing/wrong CSS propertiesWebPositive: missing text-shadow, box-shadow support, broken border-radius support

comment:5 Changed 3 years ago by pulkomandy

Do you have a website where I can test this?

comment:6 Changed 3 months ago by waddlesplash

Resolution: invalid
Status: newclosed

No reply, and the major issue was tracked and fixed in a separate ticket.

comment:7 Changed 3 months ago by pulkomandy

Resolution: invalid
Status: closedreopened

Shadows are still not implemented.

comment:8 Changed 3 months ago by dsjonny

Unfortunatelly I have less time for Haiku, but now put the latest nightly anyboot (hrev52824) image to Hyper-V and checked one of my latest website (fonalfeszek.hu) and some CSS not working instead of other browsers:

  • opacity != 1
  • @font-face
  • box-shadow

It would be a big help if I can use developer/debugger tools in the browser.

Note: See TracTickets for help on using tickets.