Opened 12 years ago

Closed 11 years ago

#974 closed bug (fixed)

colored menus issues

Reported by: diver Owned by: stippi
Priority: normal Milestone: R1
Component: Kits/Interface Kit Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

If you change menu color via Menus first menuitem text everywhere will be corrupted. Steps to reproduce:

  1. Change menu color (for example 51,102,152 like desktop colors)
  2. Restart deskbar.
  3. Click Leaf menu.

Tested under vmware with 19802.

Change History (6)

comment:1 Changed 12 years ago by jackburton

Component: Kits/Application KitKits/Interface Kit
Owner: changed from axeld to jackburton
Summary: [application_kit] colored menus issuescolored menus issues

comment:2 Changed 12 years ago by stippi

Owner: changed from jackburton to stippi
Status: newassigned

There are some issues with the Menu preflet preview of a menu when changing colors, but the menus itself should be working correctly since a few revisions.

comment:3 Changed 12 years ago by diver

I tested again and found out that main Deskbar window doesn't change it's color according to Menu preflet, it stays default. And fonts of Deskbar's main window are corrupted.

comment:4 Changed 11 years ago by jackburton

Resolution: fixed
Status: assignedclosed

This was fixed some time ago.

comment:5 Changed 11 years ago by diver

Resolution: fixed
Status: closedreopened

I can still reproduce corrupted fonts in Deskbar, reopening.

comment:6 Changed 11 years ago by stippi

Resolution: fixed
Status: reopenedclosed

Fixed in hrev28030. Changes to the system wide menu color will take effect when restarting the DeskBar. If the changes are to be used live, I suggest we implement this for all menus at once, not only DeskBar.

Note: See TracTickets for help on using tickets.