Opened 12 years ago

Closed 11 years ago

Last modified 11 years ago

#973 closed bug (fixed)

[Tracker] crash on quit via ProcessController

Reported by: diver Owned by: axeld
Priority: normal Milestone: R1
Component: Applications/Tracker Version: R1/pre-alpha1
Keywords: Cc: marcusoverhagen
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Tracker will crash or lockup if you quit it via ProcessController. Steps to reproduce:

  1. Click Leaf Menu.
  2. Configure Leaf menu.
  3. Click "Add..." button.
  4. Close Configure Leaf menu, but don't close BFilePanel.
  5. Quit Tracker via PorcesController.

Tested under vmvare with hrev19802. Back trace will follow.

Attachments (2)

tracker_crash.PNG (40.5 KB) - added by diver 12 years ago.
back trace
Tracker_Crash_on_quit_r25947_gcc4.txt (5.1 KB) - added by umccullough 11 years ago.
Tracker crash on quit hrev25947 GCC4

Download all attachments as: .zip

Change History (18)

Changed 12 years ago by diver

Attachment: tracker_crash.PNG added

back trace

comment:1 Changed 12 years ago by axeld

Cc: marcusoverhagen added

If I close the "Configure Leaf Menu" window, the file panel is closed, too. Anyway, I can't reproduce this bug at all.

comment:2 Changed 12 years ago by axeld

BTW are you both (Diver, Marcus) building Haiku under Linux? Does it happen on real hardware, emulation (which one), or both?

comment:3 Changed 12 years ago by diver

I've used precompiled image from here http://haikuhost.com/housestrain/ I think it was build under lunux.

comment:4 Changed 12 years ago by diver

Oh and i tested it under vmware.

comment:5 Changed 12 years ago by marcusoverhagen

Vmware images build under Linux with gcc 2.9*, tested with vmware player for Linux. The crashing is very random, it doesn't always happen.

comment:6 Changed 12 years ago by marcusoverhagen

I'll upload an image for a reproduceable crash.

Do nothing else, directly after start:

1) In Deskbar menu, chose Application / ProcessController and install it in the Deskbar

2) From the Deskbar, use ProcessController - "Quit an Application" to quit Tracker, it will crash in "typeinfo name for _BAlertFilter_

Sometimes bootscript crashes, too. I've seen it once with this image.

The image is hrev20012 but I modified the build script to not include the vmware graphics driver, so it's running with vesa.

comment:7 Changed 12 years ago by marcusoverhagen

Trac said:

Internal Error
Maximum attachment size: 500000 bytes

The attachment is puny 31 MB, but I don't have webspace access right now, sorry.

comment:8 Changed 12 years ago by diver

Can't reproduce it anymore, fixed?

comment:9 Changed 12 years ago by stippi

Maybe it is a different bug, but I tried twice and Tracker crahsed twice when quitting it from ProcessController:

GNU gdb 6.3 Copyright 2004 Free Software Foundation, Inc. GDB is free software, covered by the GNU General Public License, and you are welcome to change it and/or distribute copies of it under certain conditions. Type "show copying" to see the conditions. There is absolutely no warranty for GDB. Type "show warranty" for details. This GDB was configured as "i586-pc-haiku"...(no debugging symbols found)

Thread 193 called debugger(): pure virtual method called

Reading symbols from /system/lib/libbe.so...(no debugging symbols found)...done.Loaded symbols for /system/lib/libbe.so Reading symbols from /system/lib/libtracker.so...(no debugging symbols found)...done. Loaded symbols for /system/lib/libtracker.so Reading symbols from /system/lib/libroot.so...done. Loaded symbols for /system/lib/libroot.so Reading symbols from /system/lib/libqoca.so...done. Loaded symbols for /system/lib/libqoca.so Reading symbols from /system/lib/libstdc++.hrev4.so...done. Loaded symbols for /system/lib/libstdc++.hrev4.so Reading symbols from /system/lib/libtranslation.so...done. Loaded symbols for /system/lib/libtranslation.so Reading symbols from /system/lib/libtextencoding.so...done. Loaded symbols for /system/lib/libtextencoding.so

[Switching to team /system/Tracker (183) thread w>Desktop (193)] 0xffff0102 in ?? () (gdb) bt #0 0xffff0102 in ?? () #1 0x0068907e in debugger () from /system/lib/libroot.so #2 0x0068538a in pure_virtual () from /system/lib/libroot.so #3 0x0057c6eb in BPrivate::IconCache::Draw () from /system/lib/libtracker.so #4 0x005a4301 in BPrivate::BPose::DrawIcon () from /system/lib/libtracker.so #5 0x005a3a1a in BPrivate::BPose::Draw () from /system/lib/libtracker.so #6 0x005c2da0 in BPrivate::BPoseView::DrawViewCommon ()

from /system/lib/libtracker.so

#7 0x005c27b0 in BPrivate::BPoseView::Draw () from /system/lib/libtracker.so #8 0x00368efe in BView::_Draw () from /system/lib/libbe.so #9 0x0036d1f9 in BWindow::DispatchMessage () from /system/lib/libbe.so #10 0x0037089f in BWindow::task_looper () from /system/lib/libbe.so #11 0x002c575f in BLooper::_task0_ () from /system/lib/libbe.so #12 0x0068d3b0 in thread_entry () from /system/lib/libroot.so #13 0x70184fec in ?? () (gdb)

comment:10 Changed 11 years ago by aldeck

Resolution: fixed
Status: newclosed

I've been doing this a lot when debugging Tracker. Did ctrl-c and processcontroller->quit->Tracker hundreds of times. Never got a crash. Must have been fixed in the mean time.

comment:11 Changed 11 years ago by anevilyak

Did you try on gcc4 by any chance? Most of the Tracker crash on quit errors I've heard were from people using those builds.

comment:12 Changed 11 years ago by aldeck

Hmm, i don't have a gcc4 build at hand, can you check?

comment:13 Changed 11 years ago by anevilyak

I can try, but I honestly haven't seen that particular bug here myself...I'm not on an SMP system here though, so that may be part of it. Urias might be able to, assuming he sees this, I remember him reporting that problem.

comment:14 Changed 11 years ago by umccullough

I'll give it another try shortly.

Most of the time, when using a GCC4 build, it crashes at shutdown/restart. I can't say I've ever manually quit it intentionally and checked the backtrace.

Changed 11 years ago by umccullough

Tracker crash on quit hrev25947 GCC4

comment:15 Changed 11 years ago by umccullough

I attached a backtrace from the crash when quitting Tracker on a GCC4 build of hrev25947 here.

Note it dies in a very slightly different place.

comment:16 Changed 11 years ago by umccullough

FWIW, the gcc4 Tracker crash on quit issue I was having before seems to be gone since hrev26383 now.

Since this bug is still closed, this is just for information only.

Note: See TracTickets for help on using tickets.