Opened 7 years ago

Closed 7 years ago

#9746 closed enhancement (duplicate)

Behaviour of Deskbar's auto-raise

Reported by: Giova84 Owned by: axeld
Priority: normal Milestone: R1
Component: Applications/Deskbar Version: R1/Development
Keywords: deskbar autoraise behaviour Cc:
Blocked By: #8923 Blocking:
Platform: All

Description

I have enabled the auto-raise feature of Deskbar, since i found this feature very useful. But this feature not always act in the same way.

An example:

I start a browser (or any other app, like WonderBrush, which have the color selector in the upper right part) and i click in the upper right section (eg inside the web search form) and behind this part of the browser's window is present the Deskbar. Ok: as i click in the upper right part of the browser (or WonderBrush), the Deskbar will auto raise [Remember this note as "NOTE1"]. If i want to have again the browser on top, the only way that i have, is to do a single click on the tab name or on the frame of the browser window: but the browser window will not back on top if i click inside his window; this will only happen if i have another application in front of the browser and then i hide this application: in this way i can send the Deskbar (again) on background. Once i have sent the Deskbar on background (clicking on tab or on frame of the browser or again inside the window), if i click again in the upper right section of the browser [NOTE1], Deskbar will not auto raise again: to do this i have to click on the visible part of the Deskbar which appears behind the browser.

I set this ticket as enhancement, since i think that auto raise and "on top" of applications could be improved to have always the same behaviour (as is described in ticket, these features doesn't always act at the same ways). And a consideration about this, is the fact that could be a little bit annoying the fact that Deskbar will auto raise when we do an operation (eg using the browser to do a web search, so we are typing, or while we are working with wonderbrush, while we're selecting colors: in this last case is very annoying the fact that the Deskbar will always appears during colors selection, expecially when the window is to full screen). Maybe the auto raise could be activated when the mouse is on the visible part of the Deskbar (look at the screenshot "Visible_Deskbar.png").

I hope i was clear; could seems difficult to understand properly, but is easy to reproduce :-)

Attachments (1)

Visible_Deskbar.png (31.9 KB ) - added by Giova84 7 years ago.

Download all attachments as: .zip

Change History (3)

by Giova84, 7 years ago

Attachment: Visible_Deskbar.png added

comment:1 by Giova84, 7 years ago

This ticket looks like a dup of #8923 and the description could be summarized with this comment: https://dev.haiku-os.org/ticket/8923#comment:1

comment:2 by anevilyak, 7 years ago

Blocked By: 8923 added
Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.