Opened 6 years ago

Closed 6 years ago

#9796 closed bug (duplicate)

Fixed-width MenuField as BBox label grows when item is selected

Reported by: jscipione Owned by: axeld
Priority: normal Milestone: R1
Component: Kits/Interface Kit Version: R1/Development
Keywords: Cc:
Blocked By: #2413 Blocking:
Has a Patch: no Platform: All

Description

In the case of a fixed-width menu field used as the label of a BBox each time you select an item from the menu the menu field grows a bit wider.

This can most easily be tested using the Backgrounds preflet selecting between All Workspaces and Current Workspace. The problem seems to occur only if the menu field is in fixed width mode and doesn't use the layout APIs, i.e. a frame rectangle is specified.

This has been a problem since before R1/A2 but was not present in R1/A1.

Change History (3)

comment:1 by diver, 6 years ago

Sounds related to #2413.

in reply to:  1 comment:2 by jscipione, 6 years ago

Replying to diver:

Sounds related to #2413.

It seems like you're right, I'm not surprised given the apparent age of this bug. I'm not sure if I should close this ticket as a duplicate though because the problem described in #2413 has since been worked-around even though the underlying problem that caused both tickets is still with us. I wouldn't be offended if this ticket we're closed as a duplicate of #2413 though since they both describe the same issue, I've just added a few more details.

comment:3 by jscipione, 6 years ago

Blocked By: 2413 added
Resolution: duplicate
Status: newclosed

Quasi-duplicate of #2413

Note: See TracTickets for help on using tickets.