Opened 6 years ago

Closed 6 years ago

#9853 closed bug (fixed)

Intel Extreme driver is not loading.

Reported by: Bouncer Owned by: axeld
Priority: normal Milestone: R1
Component: Drivers/Graphics/intel_extreme Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

My Acer 7750 laptop - simply refuses to load the Intel Extreme driver. It always boots with the VESA driver, and denies me the high resolution I expect.

'listdev' shows the following - so I know the 'Intel Extreme' is there.

device Display controller (VGA compatible controller, VGA controller) [3|0|0]
  vendor 8086: Intel Corporation
  device 0116: 2nd Generation Core Processor Family Integrated Graphics Controller

In the Syslog file - the intel_extreme driver stops after the message: "error: could not map GART aperture!"

I am attaching the lisdev and syslog files.

I have tried to research this - and it seems similar to the very old ticket #1969

I tested this with a GCC4 compile of hrev 45814. On a ACER 7750 laptop (i7, HD3000).

Attachments (3)

syslog.h45814.txt (160.3 KB ) - added by Bouncer 6 years ago.
Syslog file.
listdev.txt (2.3 KB ) - added by Bouncer 6 years ago.
Devices listed by listdev
syslog.diag.gcc4.45817 (160.6 KB ) - added by Bouncer 6 years ago.
gcc4 hrev45817 tracing enabled in "intel_gart.cpp"

Download all attachments as: .zip

Change History (11)

by Bouncer, 6 years ago

Attachment: syslog.h45814.txt added

Syslog file.

by Bouncer, 6 years ago

Attachment: listdev.txt added

Devices listed by listdev

comment:1 by anevilyak, 6 years ago

Component: Audio & VideoDrivers/Graphics/intel_extreme
Owner: changed from nobody to axeld
Version: R1/alpha4.1R1/Development

comment:2 by korli, 6 years ago

Is it a GCC4 32bit build?

comment:3 by Bouncer, 6 years ago

Yes - a GCC4 32bit build. But not a Hybrid. Cross compiled on Ubuntu Linux.

In case there is any question, my BTools is at btrev43508.

comment:4 by korli, 6 years ago

Could you activate tracing in src/add-ons/kernel/busses/agp_gart/intel_gart.cpp line 17, build "<agp_gart>intel" and update this module? You'll see there are not many possible failure cases: not found bridge, memory allocation or mapping failures.

comment:5 by Bouncer, 6 years ago

I tried activating tracing as you suggested. The only new information is that the "could not map GART aperture" error occures immediatly after a a line showing "agp-intel: bus manager init"

I will attempt to attach the new syslog.

By the way. I also tried a test using the latest nightly (gcc2-hybrid 45817). I get the exact same error as shown in my gcc4 compiles.

by Bouncer, 6 years ago

Attachment: syslog.diag.gcc4.45817 added

gcc4 hrev45817 tracing enabled in "intel_gart.cpp"

comment:6 by korli, 6 years ago

OK then the probing phase failed because it should have displayed "found intel bridge". Could you have a try with hrev45822?

comment:7 by Bouncer, 6 years ago

Success! Haiku now loads the Intel_extreme video driver. I am now setting higher video resolutions. Thanks!

comment:8 by korli, 6 years ago

Resolution: fixed
Status: newclosed

Thanks for the feedback!

Note: See TracTickets for help on using tickets.