Opened 5 years ago

Closed 8 days ago

#10095 closed bug (fixed)

wpa_supplicant crashes if cancel is pressed

Reported by: kallisti5 Owned by: mmlr
Priority: normal Milestone: R1
Component: Network & Internet/Wireless Version: R1/Development
Keywords: Cc:
Blocked By: Blocking: #11964
Has a Patch: no Platform: All

Description

hrev46224

KERN: vm_soft_fault: va 0x0 not covered by area in address space
KERN: vm_page_fault: vm_soft_fault returned error 'Bad address' on fault at 0x0, ip 0x0, write 0, user 1, thread 0x38c
KERN: vm_page_fault: thread "wpa_supplicant" (908) in team "wpa_supplicant" (908) tried to execute address 0x0, ip 0x0 ("???" +0x0)
KERN: debug_server: Thread 908 entered the debugger: Segment violation
KERN: stack trace, current PC (nil)  :
KERN:   (0x633e38a8)  0xb835c4  _ZN16WPASupplicantApp15MessageReceivedEP8BMessage + 0xb4
KERN:   (0x633e38d8)  0x249455c  _ZN7BLooper15DispatchMessageEP8BMessageP8BHandler + 0x54
KERN:   (0x633e38f8)  0x248cef5  _ZN12BApplication15DispatchMessageEP8BMessageP8BHandler + 0x39b
KERN:   (0x633e3b18)  0x249437f  _ZN7BLooper11task_looperEv + 0x1a1
KERN:   (0x633e3b68)  0x248aae7  _ZN12BApplication3RunEv + 0x5d
KERN:   (0x633e3b88)  0xb664ca  main + 0x5a
KERN:   (0x633e3bb8)  0xb6661c  _start + 0x50
KERN:   (0x633e3bf0)  0x20e2048  runtime_loader + 0x122

Change History (8)

comment:1 Changed 4 years ago by diver

Owner: changed from axeld to mmlr
Status: newassigned

comment:2 Changed 4 years ago by pulkomandy

I can't reproduce this. Cancelling the authentication dialog works fine here. However, entering the wrong password seems to put the wifi adapter in a bad state, where I can't list wireless networks anymore.

comment:3 Changed 4 years ago by jackburton

I am able to reproduce it, but not consistently. After many authentication tries (related to #8020), wpa_supplicant crashes.

comment:4 Changed 4 years ago by pulkomandy

And after another try I could reproduce it. I think you need to start with wifi disconnected (for example a fresh install where you have never paired with any wifi). Then pick one from NetworkStatus, and press cancel, and you get a crash.

If the wifi is already connected, you get no crash and the confused state I mentioned above.

comment:5 Changed 3 years ago by pulkomandy

Milestone: R1/beta1R1

comment:6 Changed 15 months ago by miqlas

Still there:

KERN: vm_page_fault: vm_soft_fault returned error 'Bad address' on fault at 0x0, ip 0x0, write 0, user 1, thread 0x28e
KERN: vm_page_fault: thread "wpa_supplicant" (654) in team "wpa_supplicant" (654) tried to execute address 0x0, ip 0x0 ("???" +0x0)
KERN: debug_server: Thread 654 entered the debugger: Segment violation
KERN: stack trace, current PC (nil)  :
KERN:   (0x7fd5f3d1fb20)  0x9994ac3501  _ZN16WPASupplicantApp15MessageReceivedEP8BMessage + 0x61
KERN:   (0x7fd5f3d1fb50)  0x18a9336cd40  _ZN7BLooper15DispatchMessageEP8BMessageP8BHandler + 0x34
KERN:   (0x7fd5f3d1fb60)  0x18a93366219  _ZN12BApplication15DispatchMessageEP8BMessageP8BHandler + 0x39b
KERN:   (0x7fd5f3d1fda0)  0x18a9336d0cc  _ZN7BLooper11task_looperEv + 0x1dc
KERN:   (0x7fd5f3d1fe00)  0x18a93362eee  _ZN12BApplication3RunEv + 0x50
KERN:   (0x7fd5f3d1fe20)  0x9994aa7e93  main + 0x43
KERN:   (0x7fd5f3d1fe40)  0x9994aa7ffe  _start + 0x54
KERN:   (0x7fd5f3d1fe70)  0x1356e540e48  runtime_loader + 0x12b
KERN: debug_server: Killing team 654 (/boot/system/bin/wpa_supplicant)
KERN: debug_server: TeamDebugHandler::Init(): Failed to get info for team 654: Operation on invalid team
KERN: debug_server: KillTeam(): Error getting info for team 654: Operation on invalid team
KERN: debug_server: Killing team 654 ()

Haiku shredder 1 hrev51206 Jun 14 2017 16:15:29 x86_64 x86_64 Haiku

comment:7 Changed 6 months ago by pulkomandy

Blocking: 11964 added

comment:8 Changed 8 days ago by waddlesplash

Resolution: fixed
Status: assignedclosed

Seems to be fixed now.

Note: See TracTickets for help on using tickets.