Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#10097 closed bug (duplicate)

DriveSetup: shows partitions on an empty drive

Reported by: dsjonny Owned by: stippi
Priority: normal Milestone: R1
Component: Applications/DriveSetup Version: R1/Development
Keywords: GPT Cc: starsseed@…, phoudoin
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Using hrev46224 nightly anyboot.

I have "cleaned up" my SSD using dd (dd if=/dev/zero of=/dev/disk/scsi/0/5/0/raw bs=1M count=64K), and after it DriveSetup (and also Tracker) still shows the partitions on the drive. I tried to mount it (just for sure), but I got an "Invalid Argument" error. When I check the raw disk using DiskProbe there are only 0 on the disk. I also tried to "Rescan" many times, but nothing changed.

Attachments (1)

DriveSetup.png (40.3 KB ) - added by dsjonny 6 years ago.

Download all attachments as: .zip

Change History (7)

by dsjonny, 6 years ago

Attachment: DriveSetup.png added

comment:1 by starsseed, 6 years ago

Cc: starsseed@… added

did you reboot your system before you enter drivesetup ? / does this still append after a reboot ?

comment:2 by dsjonny, 6 years ago

After reboot there is no problem. But I think this is not good if the system does not shows the real state of the disks. I have no idea what may be the problem.

comment:3 by kallisti5, 6 years ago

Keywords: GPT added
Resolution: duplicate
Status: newclosed

This is a duplicate of #8823. GPT places a copy of it's partition table at the beginning and end of a disk. While you erased the first copy of the partition table, you left a copy of the GPT partition table at the end of the device. We are picking up on that backup partition table.

in reply to:  3 comment:4 by dsjonny, 6 years ago

Replying to kallisti5:

This is a duplicate of #8823. GPT places a copy of it's partition table at the beginning and end of a disk. While you erased the first copy of the partition table, you left a copy of the GPT partition table at the end of the device. We are picking up on that backup partition table.

Yes, I found data at the last block on the disk using DiskProbe, and I also replace that with zero, because the last block was missed by dd.

comment:5 by kallisti5, 6 years ago

what you said :)

Here is info on how to properly wipe GPT with dd: https://moodjbow.wordpress.com/2011/08/19/erasing-gpt-disk-with-dd/

It was a good design decision for the most part, but it makes cleaning up a partition table a little more difficult.

comment:6 by phoudoin, 6 years ago

Cc: phoudoin added
Note: See TracTickets for help on using tickets.