Opened 6 years ago

Closed 4 years ago

#10178 closed bug (fixed)

aleatory vm_page_fault KDL error (usb hub or card reader)

Reported by: un_spacyar Owned by: axeld
Priority: normal Milestone: R1
Component: System/Kernel Version: R1/Development
Keywords: vfs fd Cc: degea@…
Blocked By: Blocking: #10177
Has a Patch: no Platform: x86

Description

Aleatory, Haiku enter in KDL showing "PANIC: vm_page_fault: unhandled page fault in kernel space at..."

This error not appears to be related to some application, or specific operation. I attach two screenshots, showing the same error, but asociated a differents aplications:

One appeared when closed the "Media Preferences"; and another during the execution of a script that call the "sync" command.

Haiku revision 45740 (however, I had the same issue with Alpha 4.1 too)

Attachments (2)

20131027_180610_crop.jpg (734.4 KB) - added by un_spacyar 6 years ago.
KDL capture
20131106_123038_crop.jpg (646.0 KB) - added by un_spacyar 6 years ago.
KDL capture (another one)

Download all attachments as: .zip

Change History (15)

Changed 6 years ago by un_spacyar

Attachment: 20131027_180610_crop.jpg added

KDL capture

Changed 6 years ago by un_spacyar

Attachment: 20131106_123038_crop.jpg added

KDL capture (another one)

comment:1 Changed 6 years ago by anevilyak

Blocking: 10177 added

comment:2 Changed 6 years ago by anevilyak

Component: - GeneralSystem/Kernel
Owner: changed from nobody to axeld

comment:3 Changed 6 years ago by bonefish

Keywords: vfs fd added; vm_page_fault KDL removed

Might be related to #4473 and/or #4157.

Have you by any chance used a USB stick or disk during the session?

BTW, please just leave the keywords field of the ticket empty when you report something.

comment:4 Changed 6 years ago by un_spacyar

I'm not sure, but is highly probably. If can be related to USB issues, you must know the following:

In my syslog, I get the following error constantly: KERN: usb error ehci -1: qtd (0x222e100) error: 0x800d8d40 (I get one message by second, approximately)

My LCD Screen is also a USB hub (maybe is related to this).

I will disconect / disable all USB ports and devices, and check if I get the error again.

PD: sorry for the keywords ;-)

comment:5 Changed 6 years ago by un_spacyar

well, after 10 days of testing, the problem appears to be related to the USB-Card reader/hub included in my monitor (Dell U2410). I disconected monitor's USB cable and no KDL appeared again. Also, dissapeared the "KERN: usb error ehci -1: qtd (0x222e100) error: 0x800d8d40" error from Syslog.

I used another USB devices (like External harddisks), with the USB ports from the motherboard, and no errors were found.

comment:6 Changed 6 years ago by ttcoder

Cc: degea@… added

Was seeing that one much with Dane in Alpha4.1 days and for some time afterwards; interested to see if it's gone for good in recent revs. (45800+)

comment:7 Changed 6 years ago by un_spacyar

I retested it with the following night build: 46508

However, I get the same error in the syslog file, when I connected the USB cable from the LCD:

KERN: usb hub 22: port 0: new device connected KERN: usb hub 28: port 0: new device connected KERN: usb hub 34: port 0: new device connected KERN: usb_disk: device reports a lun count of 1 KERN: usb_disk: vendor_identification "Generic " KERN: usb_disk: product_identification "Ultra HS-SD/MMC" KERN: usb_disk: product_revision_level "1.82" KERN: usb error ehci -1: qtd (0x2b93380) error: 0x000d8d40 KERN: usb error ehci -1: qtd (0x2b93e80) error: 0x800d8d40 KERN: usb_disk: got device name "Generic Ultra HS-SD/MMC 1.82": No error KERN: usb error ehci -1: qtd (0x2b94980) error: 0x800d8d40 KERN: usb error ehci -1: qtd (0x2b96380) error: 0x800d8d40 KERN: usb error ehci -1: qtd (0x2b97d80) error: 0x800d8d40 KERN: usb error ehci -1: qtd (0x2b99780) error: 0x800d8d40 KERN: usb error ehci -1: qtd (0x2b9b180) error: 0x800d8d40 KERN: usb error ehci -1: qtd (0x2b9cb80) error: 0x800d8d40 KERN: usb error ehci -1: qtd (0x2b9e580) error: 0x800d8d40 KERN: usb error ehci -1: qtd (0x2b9ff80) error: 0x800d8d40 KERN: usb error ehci -1: qtd (0x2ba1980) error: 0x800d8d40 KERN: usb error ehci -1: qtd (0x2ba3380) error: 0x800d8d40

comment:8 in reply to:  7 Changed 6 years ago by korli

Replying to un_spacyar:

I retested it with the following night build: 46508

However, I get the same error in the syslog file, when I connected the USB cable from the LCD:

KERN: usb error ehci -1: qtd (0x2ba1980) error: 0x800d8d40 KERN: usb error ehci -1: qtd (0x2ba3380) error: 0x800d8d40

AFAIK this error message is "normal" (I usually comment this error message in local builds): the card reader is constantly asked for its disk status and fails successfully when no disk is present.

comment:9 Changed 6 years ago by un_spacyar

I see... in that case, the KDL error may be related to USB issues; BUT the "KERN: usb error ehci -1: qtd " error is not related to the KDL reported initially. Correct?

Which can be the following steps? Install a recent nightly build, and check if appears another KDL?

Thank you!!!

comment:10 Changed 5 years ago by un_spacyar

Hi. I retested this ticket in recents builds (hrev48341), and is still present. Certainly, is related to the USB hub included in the DELL U2410 LCD, because if I unplug the USB hub, there are no KDL (I had Haiku running for over a week, without KDL, when the USB hub is unplugged).

comment:11 Changed 5 years ago by pulkomandy

Summary: aleatory vm_page_fault KDL erroraleatory vm_page_fault KDL error (usb hub or card reader)

comment:12 Changed 4 years ago by un_spacyar

Just an update:

Aparently, since hrev48574 can't be reproduced. Now I'm using hrev48744 and not had any problem. I will update again if appears again.

comment:13 Changed 4 years ago by pulkomandy

Resolution: fixed
Status: newclosed

ok, closing ticket for now then, we can reopen if you manage to trigger it again.

Note: See TracTickets for help on using tickets.