Opened 6 years ago

Closed 6 years ago

#10306 closed bug (invalid)

No "Line commenting" on bitbucket pull requests

Reported by: humdinger Owned by: pulkomandy
Priority: normal Milestone: R1
Component: Applications/WebPositive Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

This is hrev46528.

When you review a pull request on bitbucket, you're supposed to be able to insert a comment on a specific line, by hovering the mouse over a line. A commenting icon should pop up to the left of the line number. Click it to insert the comment.
Works under Firefox in Linux, icon and functionality still missing with current WebKit/Web+.

Change History (3)

comment:1 by waddlesplash, 6 years ago

Is the equivalent GitHub functionality also broken?

comment:2 by humdinger, 6 years ago

I have no possibility of testing that, but friend DeadYak assured me this functionality is using HTML5 and JS. So a fix seems possible.

comment:3 by humdinger, 6 years ago

Resolution: invalid
Status: newclosed

It might be it was my fault... could be that I was logged out at the time (though I'm pretty sure I logged in before...).
Just tried again and now it works, though the icon that appears to the left of a line and has to be clicked to start commenting, is just a box. Also all formatting-icons in the editor box that appears then are grey. So, bitbucket pull-requests might still be a good object to improve rendering...

Note: See TracTickets for help on using tickets.