Opened 6 years ago

Closed 10 months ago

#10310 closed bug (fixed)

Regression : broadcom570x blocks on boot

Reported by: Barrett Owned by: Barrett
Priority: normal Milestone: R1
Component: Drivers/Network/broadcom570x Version: R1/Development
Keywords: boot-failure Cc:
Blocked By: #12222 Blocking:
Has a Patch: no Platform: All

Description

From my last update i have my system which is not booting at all. It sometimes block on rocket, but in majority of cases it show just a black screen. Anyway, it's booting with safe mode activated (without video support).

I tested various revs, and i can say the regression was between :

45c56fdb6b6ac5a882d597d3337e860cd726a11a

and

4377c66f87368091b4d7ceed5aa08c2bbdb6b134

The first is a working rev, the second is non-working.

My pc is an Acer 5738Z. Unfortunately, is not created any syslog to attach.

Attachments (1)

bcm5x_bug.jpeg (803.0 KB) - added by Barrett 6 years ago.
BCM5x driver debug screenshot

Download all attachments as: .zip

Change History (20)

comment:1 Changed 6 years ago by anevilyak

Cc: korli added

comment:2 Changed 6 years ago by Barrett

An update...after opening the ticket i rebooted, and i become crazy because it wasn't booting. I've then tested those revs :

c9a56147d2de5fcdd44da46e02c22770070cdd5c

e3ca61af3262f112788c14a93129736f543a83af

I rebooted and both were not working. So i launched linux, and then before to log-in rebooted to Haiku, it booted.

I don't know what exactly is, but basically after the image is written, i have to reboot two times to get it booting.

comment:3 Changed 6 years ago by Barrett

Ok, it's going to be a lot more strange. Sometimes boot, sometimes not. I started the pc, Haiku booted, then rebooted and it blocked at the rocket icon. If someone have some further test just let me know.

comment:4 Changed 6 years ago by umccullough

Is it just an issue of warm vs cold boot? Sometimes the hardware gets left in a bad state if the driver doesn't clean up properly.

Also, I know I've run into situations where booting into Windows or Linux seems to configure the hardware in such a way that it will reboot into Haiku without problem...

comment:5 Changed 6 years ago by korli

If you could boot in safe mode and start servers one by one, this would help to see which driver is misbehaving. Why do you think it's ACPI related?

comment:6 Changed 6 years ago by korli

Summary: Regression : Haiku can't book (ACPI)Regression : Haiku can't boot (ACPI)

comment:7 Changed 6 years ago by Barrett

@umccullough

Really...don't have idea of what it's. Sometimes Haiku boot correctly, but at the next reboot it block, sometimes i have to pass through linux, sometimes i can pray god for a day but it won't boot. What i can say, seems that in september end revs there's not this problem.

@korli

At this point i'm not sure anymore it's acpi related, I thinked of it, because revs before the ACPI changes apparently booted correctly, but it looks like i was deceived by this strange behaviour.

I'll do those tests, trying also to blacklist the acpi driver, and let you know...

comment:8 Changed 6 years ago by Barrett

I tested a bit more, and blacklisting the acpi_battery driver, solve the problem.

comment:9 Changed 6 years ago by Barrett

I'm full of false positives, very sorry about that, also without the drivers it continue to boot intermittently, with apparently no sense at all.

I tried to start the servers one by one with haiku booted in safe mode, but i'm unable to identify which component is causing the problem. Might it be some conflict between drivers?

Changed 6 years ago by Barrett

Attachment: bcm5x_bug.jpeg added

BCM5x driver debug screenshot

comment:10 Changed 6 years ago by Barrett

I've finally found the source of the problem enabling on-screen debug. The BCM5x block up, unfortunately i don't know why this happens intermittently.

comment:11 Changed 6 years ago by korli

Cc: korli removed
Component: Drivers/ACPIDrivers/Network/broadcom570x
Owner: changed from tqh to nobody
Summary: Regression : Haiku can't boot (ACPI)Regression : broadcom570x blocks on boot

Could you eventually find the first non working revision? I suppose that, when you disable the driver broadcom570x, the problem doesn't occur anymore?

comment:12 Changed 6 years ago by Barrett

Yes disabling the driver, the problem disappear. I was far from the pc with this hardware, i'll try to find the non working rev in the next weeks.

comment:13 Changed 5 years ago by luroh

Blocking: 7665 added

comment:14 Changed 4 years ago by Barrett

Owner: changed from nobody to Barrett
Status: newassigned

comment:15 Changed 4 years ago by Barrett

Blocked By: 12222 added

(In #12222) The same here with a BCM5784M, it seems a problem of the BCM* drivers or the FreeBSD compatibility layer. Duplicate of #10310.

comment:16 Changed 14 months ago by waddlesplash

Still an issue after the FreeBSD 11 upgrade?

comment:17 Changed 14 months ago by waddlesplash

Keywords: boot-failure added

comment:18 Changed 14 months ago by waddlesplash

Blocking: 7665 removed

comment:19 Changed 10 months ago by waddlesplash

Resolution: fixed
Status: assignedclosed

Fixed in hrev52204; the hang location is even identical to #10673.

Note: See TracTickets for help on using tickets.