Opened 6 years ago

Closed 4 years ago

#10443 closed bug (duplicate)

Kernel Panic after installing from flash drive

Reported by: vidrep Owned by: axeld
Priority: normal Milestone: R1/beta1
Component: File Systems/BFS Version: R1/Development
Keywords: Cc:
Blocked By: #9449 Blocking: #10462
Has a Patch: no Platform: All

Description

After installing from flash drive, reboot and kernel panic.

Attachments (1)

IMG_0114 (Large).JPG (203.3 KB ) - added by vidrep 6 years ago.

Download all attachments as: .zip

Change History (15)

by vidrep, 6 years ago

Attachment: IMG_0114 (Large).JPG added

comment:1 by vidrep, 6 years ago

A suggestion, is to have installer application unmount the installation media after the install is complete, and prompt the user to remove the USB stick or CD before rebooting the system.

Last edited 6 years ago by vidrep (previous) (diff)

comment:2 by anevilyak, 6 years ago

Blocking: 10462 added

(In #10462) Indeed, thanks for the hint.

comment:3 by kallisti5, 6 years ago

Component: - GeneralFile Systems/BFS
Milestone: R1R1/alpha5
Owner: changed from nobody to axeld

Ideally we may want to avoid a kdl in this situation as from the end user perspective a kdl is *really* bad. This comes with data loss, but a notification or BAlert may be better?

Placing in alpha5 bucket with this in mind.

comment:4 by Kenboo, 6 years ago

Cc: LeiAndKo@… added

comment:5 by Kenboo, 5 years ago

Cc: LeiAndKo@… removed

comment:6 by Kenboo, 5 years ago

Also I am just a observer here but, it seems with the new nightly build (hrev47469) this problem is not appear. Therefore my suggestion is try it again, please.

Last edited 5 years ago by Kenboo (previous) (diff)

comment:7 by vidrep, 5 years ago

Wrote hrev47844 to flash drive from within a4.1. First install boot resulted in KDL. Second attempt resulted in successful installation to hard drive, with KDL on restart. Third boot was successful, until media server crashed. So, apparently it is not yet fixed. I also tried install from a CD using the CD iso image without any problems. This appears to be a anyboot/USB issue only.

Last edited 5 years ago by vidrep (previous) (diff)

comment:8 by waddlesplash, 5 years ago

Writing to a flash drive from A4 requires use of the new makebootable. Did you use that, or the A4 makebootable?

comment:9 by vidrep, 5 years ago

dd if=/boot/home/Downloads/dev/haiku-nightly-anyboot.image of=/dev/disk/usb/0/0/raw bs=1M

The USB drive is only being used as an installation medium to install to a hard drive partition. When I write the CD iso image or anyboot image to a CD I do not encounter any such issues.

comment:10 by pulkomandy, 5 years ago

Milestone: R1/alpha5R1/beta1

comment:11 by pulkomandy, 5 years ago

The panic is a failure to write to one of the discs when unmounting it. Since this does not happen when running from a CD, I assume it is a failure to unmount the flash drive. Did you try a different flash drive to see if the issue is hardware specific?

comment:12 by vidrep, 5 years ago

Using hrev48565 x86_gcc2, I downloaded hrev48669 x86_gcc2 anyboot image and wrote it to a pair of flash drives from two different manufacturers. I wrote the image file to the flash drives using the following command:

dd if=/boot/home/haiku-nightly-anyboot.image of=/dev/disk/usb/0/0/raw bs=1M

After rebooting with the flash drive as the install medium and successfully installing to an empty partition, it KDL's as before (while shutting down for reboot). This is a different PC than what I was using previously, when the ticket was opened 1 year ago.

comment:13 by vidrep, 4 years ago

This ticket sounds a lot like earlier bug report #9449.

comment:14 by pulkomandy, 4 years ago

Blocked By: 9449 added
Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.