Opened 5 years ago

Closed 7 months ago

#10451 closed bug (invalid)

Freeze in last icon (Rocket)

Reported by: greekboy Owned by: pdziepak
Priority: normal Milestone: R1
Component: System Version: R1/Development
Keywords: boot-failure Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I have a PC Desktop and a Laptop. I am Haiku user, my PC work fine for 3 1/2 years. But after rev46684, I can't install Haiku in my PC.

Boot from x86 GCC 2 Hybrid Anyboot hrev46684 working

hrev46699 not working hrev46706 not working hrev46720 not working

If Boot from x86 GCC 2 Hybrid ISO, gets KDL.

Not sure, I think the problen is the after scheduler merge.

My PC Desktop: Asus P7H57D-V EVO CPU i7 860 Ram Memory 8GB

My Laptop works fine. Thanks.

Attachments (10)

DSC_0151.jpg (1015.8 KB) - added by greekboy 5 years ago.
8 cores.jpg (134.1 KB) - added by greekboy 5 years ago.
4 cores.jpg (135.3 KB) - added by greekboy 5 years ago.
2 cores.jpg (403.8 KB) - added by greekboy 5 years ago.
2cores-KDL_message.jpg (414.2 KB) - added by greekboy 5 years ago.
x86_64_KDL.jpg (1.1 MB) - added by greekboy 5 years ago.
DSC_0004.jpg (1.1 MB) - added by greekboy 5 years ago.
previous_syslog (188.8 KB) - added by greekboy 5 years ago.
syslog (147.2 KB) - added by greekboy 5 years ago.
syslog.old (512.0 KB) - added by greekboy 5 years ago.

Change History (35)

Changed 5 years ago by greekboy

Attachment: DSC_0151.jpg added

comment:1 Changed 5 years ago by greekboy

Sorry.

My laptop works fine with x86 GCC 2 Hybrid Anyboot (hrev46699, hrev46706, hrev46720)

But gets KDL if Boot from x86 GCC 2 Hybrid ISO hrev46720, like my PC Desktop.

comment:2 Changed 5 years ago by luroh

Could this be #8345?

comment:3 in reply to:  2 Changed 5 years ago by greekboy

Replying to luroh:

Could this be #8345?

I don't now.

But, now I tested x86 GCC 2 Hybrid ISO hrev46720, in my PC Desktop with VirtualBox.

Gets KDL with 8, 4, and 2 CPU cores. With 1 CPU Core its working.

Changed 5 years ago by greekboy

Attachment: 8 cores.jpg added

Changed 5 years ago by greekboy

Attachment: 4 cores.jpg added

comment:4 Changed 5 years ago by greekboy

With CPU 2 cores, light on the last icon (rocket) and gets KDL.

Last edited 5 years ago by greekboy (previous) (diff)

Changed 5 years ago by greekboy

Attachment: 2 cores.jpg added

comment:5 Changed 5 years ago by korli

Could be a variant of #8345 with 4 or 8 cores. The KDL message is lacking for the 2 cores KDL, please type "message" on the KDL prompt.

Your VM is named x64, is it a mistake?

comment:6 Changed 5 years ago by greekboy

The VirtualBox for Haiku is names X64, is a simple name. The VirtualBox run on Ubuntu 12.10 (i386 - 32bit).

Look the picture for "message".

Changed 5 years ago by greekboy

Attachment: 2cores-KDL_message.jpg added

comment:7 Changed 5 years ago by pdziepak

The problem you encounter when booting with 2 CPUs is #10445, which should be already fixed in hrev46726.

comment:8 Changed 5 years ago by greekboy

Testing with x86 GCC 2 Hybrid Anyboot (hrev46729), in VirtualBox.

With CPU 2 Cores - working - fixed.

But for CPU 4 Cores or 8 Cores not working, I have same KDL. (Look 8 cores.jpg, 4 cores.jpg)

comment:9 Changed 5 years ago by greekboy

Sorry for my previous post, I mean hrev46732.

Testing with hrev46746, not working.

comment:10 Changed 5 years ago by greekboy

Some notes, I hope to help you.

I testing with hrev46752 (build myself)

In Ubuntu 12.10 (32bit) and Ubuntu 12.10 (64bit)

  • x86gcc2hybrid works with CPU 1 Core or 2 Cores.
  • x86gcc4hybrid works with CPU from 1 to 7 Cores. With CPU 8 Cores not works.

Testing only Ubuntu 12.10 (64bit)

  • x86_64 works fine, without problems.

comment:11 Changed 5 years ago by pdziepak

Owner: changed from nobody to pdziepak
Status: newin-progress

comment:12 Changed 5 years ago by pdziepak

The remaining problems should be fixed in hrev46779. Please confirm.

comment:13 Changed 5 years ago by greekboy

Testing with hrev46779.

In VirtualBox works perfect!

In real hardware (PC Desktop) not works.

  1. With anyboot image all icons are color (light-up) and stopped, without KDL.
  2. With CD-ROM all icons are gray and stopped, without KDL.

comment:14 Changed 5 years ago by greekboy

Testing with hrev46780. (build myself)

In real hardware.

With image x86gcc2hybrid all icons light on and stopped. With image x86gcc4hybrid all icons light on and stopped.

With image x86_64 all icons light on and stopped, but twice i have got the installer and Desktop, once time get KDL.

Last edited 5 years ago by greekboy (previous) (diff)

Changed 5 years ago by greekboy

Attachment: x86_64_KDL.jpg added

comment:15 Changed 5 years ago by greekboy

I think is not your problem for boot. I want test old revisions from hrev46685 to hrev46698. What is the command for GIT?

comment:16 Changed 5 years ago by korli

the x86_64 problem is traced in #10458.

comment:17 Changed 5 years ago by greekboy

Same problem with hrev46922 and hrev46947 and older revisions. (x86 GCC2 Hybrid Anyboot) All icons are color (light-up) and stopped.

I' ll upload a debug syslog (photo). I think, the problem is " usb error ehci -1: qtd (0xa30ad80) error: 0x800d8d40 "

I' ll hope fix soon.

Changed 5 years ago by greekboy

Attachment: DSC_0004.jpg added

comment:18 Changed 5 years ago by umccullough

Failure reading a USB stick? Have you tried using a different stick (preferably a different brand/model even), or CD boot?

comment:19 Changed 5 years ago by greekboy

Yes, I tried different stick. Works with hrev46684 and older, after this revision I can't install.

comment:20 Changed 5 years ago by luroh

Blocking: 7665 added

comment:21 Changed 5 years ago by greekboy

I can install Haiku and working with Haiku, only in safe mode. In safe mode options, i disable ACPI. But the Haiku not working smooth. I upload the syslog files.

Changed 5 years ago by greekboy

Attachment: previous_syslog added

Changed 5 years ago by greekboy

Attachment: syslog added

Changed 5 years ago by greekboy

Attachment: syslog.old added

comment:22 Changed 12 months ago by waddlesplash

Keywords: boot-failure added

comment:23 Changed 12 months ago by waddlesplash

Blocking: 7665 removed

comment:24 Changed 9 months ago by waddlesplash

Still an issue?

comment:25 Changed 7 months ago by waddlesplash

Resolution: invalid
Status: in-progressclosed

No reply, closing.

Note: See TracTickets for help on using tickets.