Opened 5 years ago

Closed 3 years ago

#10534 closed bug (fixed)

Web+ crash in WebCore::EventListenerIterator::nextListener() + 0x4f

Reported by: humdinger Owned by: pulkomandy
Priority: normal Milestone: R1
Component: Applications/WebPositive Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

This is hrev46847.

Started Web+ with LD_PRELOAD=/system/lib/x86/libroot_debug.so. After quite a while I got the attached crash. For some reason, running with the libroot_debug.so seems to make Web+ more stable. At least it feels like I get more frequent crashes when running it regularly (BUrlProtocol.HTTP seems to be the culprit then most of the time)

I'm not sure if the summary to this ticket is correct. Please adjust if necessary...

Attachments (1)

WebPositive-5131-debug-12-02-2014-09-09-01.report (139.1 KB) - added by humdinger 5 years ago.
Web+ ran with LD_PRELOAD=/system/lib/x86/libroot_debug.so

Download all attachments as: .zip

Change History (4)

Changed 5 years ago by humdinger

Web+ ran with LD_PRELOAD=/system/lib/x86/libroot_debug.so

comment:1 in reply to:  description Changed 5 years ago by kallisti5

Replying to humdinger:

For some reason, running with the libroot_debug.so seems to make Web+ more stable.

Strange... I noticed a little app I made to connect to the /dev/graphic/* devices do the same thing. It would crash normally, but run ok when I preload libroot_debug. (https://github.com/kallisti5/librendomatic)

comment:2 Changed 5 years ago by pulkomandy

Is this reproducible by anyone?

comment:3 Changed 3 years ago by pulkomandy

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.