Opened 5 years ago

Closed 5 years ago

Last modified 12 months ago

#10535 closed bug (fixed)

Only cold boot on 64 bit

Reported by: vidrep Owned by: pdziepak
Priority: normal Milestone: R1
Component: System/Boot Loader Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86-64

Description

Installed hrev46860_x86_64 using anyboot image on USB drive Will not warm boot - intermittent KDL or no boot. System must be powered down to boot 64 bit. 32 bit nightly does not have this problem. (KDL screenshot attached)

Attachments (2)

IMG_0114.JPG (1.1 MB) - added by vidrep 5 years ago.
hrev46914_x86_64_warm_boot_debug_log.txt (7.8 KB) - added by vidrep 5 years ago.

Download all attachments as: .zip

Change History (16)

Changed 5 years ago by vidrep

Attachment: IMG_0114.JPG added

comment:1 Changed 5 years ago by vidrep

This is installed to a hard drive partition.

comment:2 Changed 5 years ago by vidrep

Write hrev46885_x86_64 anyboot image to USB drive from alpha4.1. "Restart system" with USB drive inserted. Will not boot - no icons lighting. If powered down, and restarted, then it will boot.

comment:3 Changed 5 years ago by kallisti5

I can confirm seeing this issue on a Asus Zenbook. Cold boot Haiku x86_64, works fine. Warm boot Haiku x86_64, first icon never lights up.

turned on-screen debugging on during the warm boot but it doesn't get far enough to show any boot messages.

Wonder if this could be reproduced in a vm with the serial port enabled to get some log data?

comment:4 Changed 5 years ago by kallisti5

Component: - GeneralSystem/Boot Loader
Owner: changed from nobody to axeld
Platform: Allx86-64

comment:5 Changed 5 years ago by vidrep

I have my PC's set up for serial logging. If anything gets logged on warm boot, I'll attach it to the ticket.

comment:6 Changed 5 years ago by vidrep

I have attached a serial log from hrev46914_x86_64 made during warm boot from USB drive. I hope this information helps to find the problem.

Last edited 5 years ago by vidrep (previous) (diff)

Changed 5 years ago by vidrep

comment:7 Changed 5 years ago by luroh

Blocking: 7665 added

comment:8 Changed 5 years ago by vidrep

Installed hrev47847 to hard drive partition. Icons will not light on warm boot. Must shut down system and cold boot.

comment:9 Changed 5 years ago by diver

Owner: changed from axeld to xyzzy
Status: newassigned

comment:10 Changed 5 years ago by pulkomandy

Confirmed here as well. Seems to be a rather common problem then.

comment:11 Changed 5 years ago by pdziepak

Owner: changed from xyzzy to pdziepak

comment:12 Changed 5 years ago by pdziepak

Resolution: fixed
Status: assignedclosed

Fixed in hrev47851. Commit c343f75d76653c4daaf630e4b288cec47d20de94 fixes the assertion fail reported in the attached text log. The other commit fixes the failure from the attached photo (or rather, I encountered a failure that looked quite similar to the photo when I looked at it from the other side of the room and that patch fixed it).

comment:13 Changed 5 years ago by vidrep

Confirmed working in hrev47851.

comment:14 Changed 12 months ago by waddlesplash

Blocking: 7665 removed
Note: See TracTickets for help on using tickets.