Opened 5 years ago

Closed 5 years ago

Last modified 11 months ago

#10706 closed bug (duplicate)

Segment violation in web+'s menu_tracking thread

Reported by: humdinger Owned by: axeld
Priority: normal Milestone: R1
Component: Kits/Interface Kit Version: R1/Development
Keywords: Cc:
Blocked By: #9251 Blocking:
Has a Patch: no Platform: All

Description

This hrev47029.

This is reproducible:

  • Invoke the menu with ALT+ESC.
  • Press CursorRight a few times to move the highlight to "History".
  • Press CursorDown to select the first item.
  • Press CursorRight.

-->Segment violation, see attached report.

Attachments (1)

WebPositive-1267-debug-21-03-2014-16-53-49.report (14.0 KB) - added by humdinger 5 years ago.
debug report of the segment violation

Download all attachments as: .zip

Change History (5)

Changed 5 years ago by humdinger

debug report of the segment violation

comment:1 Changed 5 years ago by anevilyak

Component: Applications/WebPositiveKits/Interface Kit
Owner: changed from pulkomandy to axeld

That's actually not Web+-specific, that's somewhere in BMenu{Bar}, and I've seen similar behavior elsewhere. Haven't ever tried to track it down though I'm afraid. I believe there's another ticket for it, but don't recall which right now.

comment:2 Changed 5 years ago by diver

Blocked By: 6846 added
Resolution: duplicate
Status: newclosed

comment:3 Changed 5 years ago by diver

Blocked By: 9251 added; 6846 removed

comment:4 Changed 11 months ago by closequarters

Just posted a patch on related ticket#9251 that was noted as blocking. For the record though, I can't reproduce the issue in WebPositive on gcc2hybrid. Of course, WebPositive has changed a lot in the last 4 years, so there's a good chance the menu structure is different as well.

Note: See TracTickets for help on using tickets.