Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#10817 closed bug (fixed)

[package_daemon] crash in PackageFileManager::GetPackageFile

Reported by: diver Owned by: bonefish
Priority: normal Milestone: R1
Component: Servers/package_daemon Version: R1/Development
Keywords: Cc: degea@…
Blocked By: Blocking: #10829
Has a Patch: no Platform: All

Description

hrev47206, x86_gcc2

I copied paladin-1.3-x86_gcc2.hpkg to /system/packages and the same moment package_daemon crashed.

PackageFileManager::GetPackageFile(entry_ref&, PackageFile&) + 0x88
[...]
PackageFileManager::CreatePackage(entry_ref&, Package&) + 0x24
Volume::_PackagesEntryCreated(char*) + 0x186
Volume::ProcessPendingNodeMonitorEvents() + 0x110
Root::_ProcessNodeMonitorEvents(Volume*) + 0x22
Root::VolumeJob::Do() + 0x69
Root::_JobRunner() + 0x3d
Root::_JobRunnerEntry(void*) + 0x1a
thread_entry + 0x21
commpage_thread_exit + 0

Attachments (1)

package_daemon-201-debug-07-05-2014-10-32-16.report (14.5 KB ) - added by diver 5 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 by ttcoder, 5 years ago

Cc: degea@… added

comment:2 by bonefish, 5 years ago

The cause is quite likely the use after deletion caused by an inverse check in PackageFile::LastReferenceReleased() (CID 1211989).

I probably won't get around fixing it before Sunday. If anyone else feels so inclined...

comment:3 by jessicah, 5 years ago

Resolution: fixed
Status: newclosed

Fixed in hrev47215

comment:4 by bonefish, 5 years ago

Blocking: 10829 added

(In #10829) Closing as duplicate of #10817. Unless anyone wants to adjust summary and description; then feel free to reopen and close as fixed in hrev47219.

Note: See TracTickets for help on using tickets.