Opened 5 years ago

Closed 11 months ago

Last modified 11 months ago

#10930 closed bug (duplicate)

BNetworkRoster::RemoveInterface() on non-existing interface KDLs

Reported by: pulkomandy Owned by: axeld
Priority: normal Milestone: R1
Component: Kits/Network Kit Version: R1/Development
Keywords: Cc:
Blocked By: #10919 Blocking:
Has a Patch: no Platform: All

Description

Compile the netapi tests and run NetworkIntrefaceTest using the UnitTester. Result is a non-continuable KDL.

The test is trying (in setUp) to remove the "loopTest" interface, to make sure it doesn't exist, before creating it. This should probably not bring the whole kernel down.

Attachments (1)

kdl.PNG (59.4 KB) - added by waddlesplash 11 months ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 5 years ago by anevilyak

This sounds like the same issue as reported in #10919, though without the actual KDL attached it's hard to say for certain.

comment:2 Changed 5 years ago by jackburton

ifconfig calls BNetworkRoster::RemoveInterface(), so I guess the cause it's the same, although the interface DOES exist in #10919.

Changed 11 months ago by waddlesplash

Attachment: kdl.PNG added

comment:3 Changed 11 months ago by waddlesplash

Still occurs indeed (attached screenshot from VMware.)

comment:4 Changed 11 months ago by diver

Blocking: 12561 added

comment:5 Changed 11 months ago by diver

Blocked By: 10919 added
Resolution: duplicate
Status: newclosed

comment:6 Changed 11 months ago by diver

Blocking: 12561 removed
Note: See TracTickets for help on using tickets.