Opened 6 years ago

Closed 6 months ago

Last modified 3 months ago

#11073 closed bug (duplicate)

[ActivityMonitor] whole applet disappears when moving a window

Reported by: jstressman Owned by: nobody
Priority: normal Milestone:
Component: Servers/app_server Version: R1/Development
Keywords: Cc:
Blocked By: #15631 Blocking:
Platform: All

Description

On hrev47509 I'm seeing pretty serious vanishing ActivityMonitor behavior when moving a window. This was on a bare metal install and tested using both the on-board nvidia video chip and an add-in radeon video card. Same behavior on both.

http://www.youtube.com/watch?v=etR4HyGFtSE

The behavior is much less noticeable in a virtualbox here, but that might be because I'm running the VM on a much more powerful computer and GPU, so it redraws a lot faster and makes it harder to notice.

http://www.youtube.com/watch?v=PfeQAbVzPFw

But as you can see it's so profound on the bare metal install as to be rather distracting.

Change History (6)

comment:1 by diver, 3 years ago

Component: - GeneralServers/app_server
Owner: changed from nobody to axeld

comment:2 by axeld, 3 years ago

Owner: changed from axeld to nobody
Status: newassigned

comment:3 by diver, 6 months ago

Blocked By: 15548 added
Resolution: duplicate
Status: assignedclosed

Can't reproduce anymore, was probably another dupe of #15548.

comment:4 by X512, 6 months ago

This is actually duplicate of #15631 and still reproduced on slow machine and VESA video driver. VESA video driver do not provide frontbuffer shifting hook (B_SCREEN_TO_SCREEN_BLIT) and backbuffer will be shifted and flushed, causing flickering.

comment:5 by diver, 6 months ago

Blocked By: 15631 added; 15548 removed

comment:6 by nielx, 3 months ago

Milestone: R1

Remove milestone for tickets with status = closed and resolution != fixed

Note: See TracTickets for help on using tickets.