Opened 12 years ago

Closed 12 years ago

#1301 closed bug (fixed)

OS becoming slow

Reported by: diver Owned by: axeld
Priority: normal Milestone: R1/alpha1
Component: System/Kernel Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Overall system becoming slow after stress testing it with opening all apps and prefs and then closing it. After that simple operations like opening a folder in tracker or moving a window will eat cpu more then usual. Seems like resource leaking or a kernel/vm bug, no?

Change History (3)

comment:1 by axeld, 12 years ago

Milestone: R1R1/alpha

comment:2 by mmlr, 12 years ago

This seems to be the same as #1117 and I think the reason was just found by Jonas Sundström on the development mailing list: http://www.freelists.org/archives/haiku-development/02-2008/msg00033.html

Caused by a large freelist and PARANOID_KFREE src/system/kernel/heap.c:623

comment:3 by mmlr, 12 years ago

Resolution: fixed
Status: newclosed

Should be "fixed" in hrev23879. Actually it was by design and a feature used for debugging. It is now only used conditionally though so it doesn't take down the system. The real fix is moving to a new allocator which does this more efficiently.

Note: See TracTickets for help on using tickets.