Opened 5 years ago

Closed 5 years ago

#11372 closed bug (fixed)

CD .wav files crash media player (64 bit)

Reported by: vidrep Owned by: pulkomandy
Priority: normal Milestone: R1
Component: Applications/MediaPlayer Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Attempting to play a CD in mediaPlayer causes an error message to be generated (see screenshot2). Video files that previously played in mediaPlayer also cause an error.

Attachments (1)

screenshot2.png (115.4 KB) - added by vidrep 5 years ago.

Download all attachments as: .zip

Change History (8)

Changed 5 years ago by vidrep

Attachment: screenshot2.png added

comment:1 Changed 5 years ago by waddlesplash

Component: Applications/MediaPlayerServers/media_addon_server
Milestone: R1R1/alpha5
Owner: changed from stippi to pulkomandy
Status: newassigned

Probably caused by PulkoMandy's changes to FFmpeg recently. Reassigning to him.

comment:2 Changed 5 years ago by mmadia

Milestone: R1/alpha5R1

comment:3 Changed 5 years ago by pulkomandy

Component: Servers/media_addon_serverApplications/MediaPlayer

Make sure your ffmpeg is up to date (version 0.11.5 is needed), and please run MediaPlayer from Terminal and share the output you get there.

Also, this has nothing to do with the media_addon_server (media plugins are not the same as media add-ons).

comment:4 Changed 5 years ago by vidrep

Ffmpeg version was 0.10.2. However, in order to update to 0.11.5 the package manager says it has to uninstall Webpositive and Haikuwebkit. I went ahead with the ffmpeg update, and CD's are now playing again. Attempting to reinstall Webpositive again brings up an error message that libavcodec is not available (see ticket #11371).

Last edited 5 years ago by vidrep (previous) (diff)

comment:5 Changed 5 years ago by waddlesplash

HaikuWebKit does not require FFmpeg directly, so I dunno what's up with that...

comment:6 Changed 5 years ago by korli

I guess that libtool has linked in transitive dependencies as usual; these have been added then in HaikuWebKit requirements. This is a topic I brought up on the mailing list without really following up.

http://www.freelists.org/post/haiku-development/libtool-link-all-deplibs,2

comment:7 Changed 5 years ago by pulkomandy

Resolution: fixed
Status: assignedclosed

It does require ffmpeg for web audio support (not the same as html5 audio). It uses it to compute Fourier transforms and other similar stuff. libtool is not involved. this is reported in #11371 already, so closing this.

Note: See TracTickets for help on using tickets.