Opened 5 years ago

Closed 3 years ago

#11431 closed bug (fixed)

[WebPositive] crashes in BUrlProtocolAsynchronousListener::MessageReceived

Reported by: DaaT Owned by: pulkomandy
Priority: normal Milestone: R1
Component: Applications/WebPositive Version: R1/Development
Keywords: Cc:
Blocked By: #11562 Blocking: #11444, #11573, #11649
Has a Patch: no Platform: All

Description

Just updated Haiku to the latest rev, 48255. Was able to reproduce this crash, had ICO open, GMail trying to open (stays as usual at the loading screen) and opened a 3rd tab with kotaku.com.

I'll attach both crash reports.

Attachments (2)

WebPositive-930-debug-09-11-2014-00-29-30.report (61.6 KB ) - added by DaaT 5 years ago.
WebPositive-2466-debug-09-11-2014-00-32-18.report (75.9 KB ) - added by DaaT 5 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 by anevilyak, 5 years ago

It's reproducible by just visiting osnews as well. I'd guess it relates to the recently implemented data blob support, and by the looks of things, somewhere in there a null function pointer is being called.

comment:2 by anevilyak, 5 years ago

Blocking: 11444 added

(In #11444) Duplicate of #11431

comment:3 by diver, 5 years ago

Summary: Web+ crash[WebPositive] crashes in BUrlProtocolAsynchronousListener::MessageReceived

comment:4 by anevilyak, 5 years ago

Blocked By: 11562 added

(In #11562) Duplicate of #11431. This crash should already be fixed in newer nightlies with WebKit 1.4.8.

comment:5 by anevilyak, 5 years ago

This one should be fixed as of hrev48415 for gcc2 builds (gcc4 and x86_64 haven't yet been updated to 1.4.8 though).

comment:6 by luroh, 5 years ago

Blocking: 11573 added

comment:7 by luroh, 5 years ago

Blocking: 11649 added

comment:8 by humdinger, 4 years ago

I see the same crash when trying to download a "report" at http://depot.haiku-os.org with hrev49167:

		0x72b76d80	0x20eac79	BUrlProtocolAsynchronousListener::MessageReceived(BMessage*) + 0x105 
		0x72b76da0	0x2b05a59	BLooper::DispatchMessage(BMessage*, BHandler*) + 0x51 
		0x72b76fc0	0x2afef1a	BApplication::DispatchMessage(BMessage*, BHandler*) + 0x2a 
		0x72b77010	0x2b05dc8	BLooper::task_looper() + 0x1c4 
		0x72b77030	0x2afbd6b	BApplication::Run() + 0x59 
		0x72b77070	0x22be469	main + 0x40 
		0x72b77098	0x22b2936	_start + 0x4b 
		0x72b770c8	0x804ad0	runtime_loader + 0x130 
		00000000	0x61e11250	commpage_thread_exit + 0

comment:9 by pulkomandy, 3 years ago

Possibly fixed in hrev50917. Can you still reproduce?

comment:10 by humdinger, 3 years ago

Resolution: fixed
Status: newclosed

No crashes when downloading a report. Looks fixed. Closing ticket. Thanks!

Note: See TracTickets for help on using tickets.